QGC stable + Copter 4.1 = Broken Configuration. PLEASE use QGC daily instead!

Hi. When I install Copter 4.1 on my H743 boards QCG 4.1.4 appears to load the params with the green progress bar, but then the state is shown as “Custom:0x0”. The Vehicle Setup page just says “QGroundControl Daily does not currently support setup of your vehicle type” and there are no config options except Parameters. But when I try to write any values via Parameters (like the Frame Class and Type) the changes aren’t committed and just revert to 0. If I try to load a saved parameter file those values don’t stick either. ie I really can’t do anything at all.

MissionPlanner seems to connect okay, but for one thing my saved parameters are a QCG params file so I want to use QGC.

If I use Plane 4.1.1 with the same setup then everything seems to work as you’d expect with QCG.

Any tips? It’s like QCG is failing to read the copter parameter metadata? Are other people seeing this with any other combinations?

Many thanks.

A workaround seems to be using Mission Planner to set the Frame Class and Type. Then QCG seems to recognise it is a copter and I was able to load my saved params and make things work.

Edit: That only lasted until the next power cycle then QCG reverts to 0 for the frame parameters, even though they are still set when I look at them with MP. Basically, if I run MP before QGC then it’s okay, but only until I reboot. After each reboot, QGC again is zero/meaningless parameters, until goto 10 and run MP again.

I’m having the exact issue with the Pixhawk 2.4.8 when upgraded to Copter 4.1.0. Had to revert to Copter 4.0.7 which has no issue. I had to however re-select the frame type once I re-flashed the firmware but I was able to get all other parameters back. I used QGroundControl to do all my flashing. I flashed the Plane version and it seemed ok so I think the issue is with the Copter version.

Yes sounds like just the same problem.

Confirm this with copter 4.1.0 and qgc 4.1.4 Mac, had to revert to 4.0.7.

Please use QGC daily instead of downgrading to 4.0.7.

We both say we’re using 4.1.4. This says “Daily Version”. It is with that version we are having the problem. Unless you’re aware of the problem having been fixed since?

Ed: Apologies.

I do not have the problem, and my version is:

QGroundControl Daily Version
Development HEAD048081 c44 2021-08-13 14:06:04 -0400

I have no clue where you got that 4.1.4 version number. I assume it is a stable version.
I do not find that number in the about page or anywhere else on my QGC GUI.

I guess it’s just a furphy “Daily Version” left in their stable release then.

Screenshot from 2021-11-05 20-46-04

The true daily/unstable version is available from this link, for those who would like to see if it fixes their issue. Please report back to confirm.


I don’t know I can agree this link provides “True Daily”…


However, I do agree that you are seeing an issue.

The setup is: QGC 4.1.4 (here: Release v4.1.4 · mavlink/qgroundcontrol · GitHub) or later (eg, daily (over a month old) at link above), and a FRESHLY updated flight controller OR requires parameters to have been reset on a 4.1+ vehicle.

This results in:

I’ve noticed that parameters that are shown as INT values cannot be modified in the UI, and revert back to 0 after I change them. If the value is FLOAT, it appears to keep that change. Thus, I CANNOT change the frame class and type from QGC in this state - Once the frame class and type is set in a different GCS, eg: MissionPlanner or MAVProxy, you can reopen QGC and it appears to function as expected. It appears to occur when the frame type and/or class is set to undefined.

Note: The QGC4.1.4 release page indicates Improved integration with AP4.1+.

Improve integration with ArduPilot 4.1+

Note: This can be easily reproduced with a vehicle. Use QGC parameter editor to restore parameters to defaults then reboot the vehicle.

Note: I’ve only tested this against Copter4.1 release.

I think the real answer is this problem is QGC side detecting what vehicle is connected and populating the UI elements accordingly.

1 Like

This is identical to my issue as well. I’ve tried MP and QGC with no proper results.

I can’t help with QGC, although it sounds like they have a beta workaround if you can find the right download.

For MP, go to the help screen and do a beta update. It will work with 4.1 after that.

Noted I will try it and report back on my finding.

I tried QGC work around, but it didn’t work.
I tried flashing using MP and all it says is download failed and doesn’t go through with firmware update.

I must note as well that the last release that was built for copter was 4.0.7. 4.0.8 was not built for copter the next release for copter was 4.1.0, could it be that something was missing from 4.0.8 but was never detected because it never had a copter build?

This was done using the latest most up-to-date versions of MP and QGC under Windows 10 (Bootcamp) and QGC under Mac OS Big Sur.

No. Ignore 4.0.8

Use 4.1.0 or 4.1.1

Use the latest betas or daily builds from GCSs


I used QGC daily build on Mac OS Big Sur, and it worked, the firmware was upgraded no issue and gave no errors. However, I am not a fan of using betas unless doing specific testing, so I went back to the stable QGC build and it came up ok but gave an error message (attached) but all seemed well after acknowledging message.


The last time I flew my battery was damaged so I am not able to test the copter’s functionality yet, but I will certainly do some more testing and share any other noticeable issues.

Please don’t do that. Use QGC daily like recommended.

Use stable 4.1.0 software on the copter. Use QGC daily because it is the only version that supports that 4.1.0 stable software

Are you aware of other compatibility issues Amil? QGC stable has presented no issues to me with copter 4.1, apart from the issues I reported when first flashing a new FC board the inconsequential MNT warnings shown by Koppa.

Yes, I am aware of other issues. That is why I, and the entire dev team, recommend the QGC daily build.

Many users, like yourself, find the hard way that QGC stable is not suitable for stable official ArduCopter 4.1.1

For the record, I thankfully did not encounter any issues beyond from those I stated above, using QGC stable since the first copter 4.1 beta release several months ago.