Servers by jDrones

QGC Radio Calibration Stops Responding

I can’t get QGC(4.0.8) to calibrate my radio (Frsky X9D+). Each time I do radio calibration QGC sees my stick input until the last stick input (pitch stick down). I’ve even tried holding the elevator stick down with a rubber band, but no matter how long the stick is down I get no response. Out of desperation I move the stick around pitch and roll. This causes QGC to accept the pitch input and combine it with roll.

While calibrating, the channel monitor monitor shows all the channels operating as expected.

What do I need to do to get radio calibration to function properly?

Turn on RadioComponentControllerLog (https://docs.qgroundcontrol.com/en/SettingsView/console_logging.html). Go through a calibration with the log on. Save the console output to a file. Attach here so I can take a look.

Don, thanks for the reply. I set the log parameters and redid the calibration. I tried putting the pitch stick down several times and then saved the log.
Radio_Calibrate.txt (574.5 KB)

I went through the logs and I think I found the problem. My channels are:
0 - Yaw
1 - Pitch
2 - Throttle
3 - Roll (Right Ail)
4 - Roll (Left Ail)
The calibration routine correctly identifies the channels for throttle and yaw. The routine sees roll on channel 3 only. Then when looking for pitch it looks at channel 4 not channel 1.

Is there something wrong with how I have my channels arranged, or does QGC just not like dual aileron channels?

QGC doesn’t know how to calibrate that kind of a setup. What parameters does that use to specify and setup a dual aileron setup like that?

On the transmitter there is one aileron input which is assigned to two output channels in mixes. In QGC the output channels are specified in servos.
I deleted one aileron in the Taranis mixes and kept the two ailerons in QGC servos. Now the Radio calibrates properly. Both ailreons work as well.

I now have a new problem. I can’t get the motor to run. My controller is a Matek F765-wing. PWMs 1 and 2 are reserved for motors. I have the ESC plugged in PWM1. Servo 1 is defined as throttle. I tried calibrating Motors, but QGC doesn’t see a motor at all. If I set servo1 up as a rudder, then the motor runs at half throttle and moving the rudder stick adjust the throttle accordingly.

Can you tell me what noob mistake am I making now? (I really hate being on this end of the learning curve. )

Current QGC is only set up to do motor testing on multi-rotor and sub. There isn’t really an api to determine how many motors a vehicle has, so no good way to generically know that. If you enter a GitHub issue for it I can see if there is some other way to support it.

Servers by jDrones