Servers by jDrones

QGC not usable on Windows 10 with 3DR radio


(Mark Brummett) #1

OK, I’ve typically been a Tower/MP kinda guy, but I love the layout and simplicity of QGC. It works great if I plug it in to USB directly, however, I’d like to have something I could connect with out in the field.

When I use my 900mhz 3DR Mavlink radio combo, I can never get it to connect. It initially (on open) complains about Mavlink protocol or Baud rate mismatch. Now, I have set my SIK radios to 115200 instead of 57600. This works fine on MP and Tower, but when I create a connection to the Com port stated, and set that connection to 115200, when I try to connect, I get Error on link COM4. Could not create port. Access is denied.

I am starting QGC as administrator. Not sure what is going on here. Any suggestions? This program works great on my old Nexus 10 but I would love to get it working on the Windows tablet I’ve been taking with me to the field.

Thanks


(Mark Brummett) #2

After some back and forth with the guys writing this, the problem has been solved.


(Anna Svagzdys) #3

What was the solution? I’m having the same issue with Windows 10. I can use the same settings and radios on Mac and Linux and it works great, but the Windows machine will not play ball.


(Binh Nguyen) #4

Hi Anna,

How did you get the 3DR telemetry to work with QGC on Mac? I’m having trouble finding where I need to go to manually set the port/connection. Thanks in advance!


(DonLakeFlyer) #5

On Windows make sure that you installed the drivers which are part of the QGC installer package. On Mac to connect to 3DR Radio you do nothing. Just plug it in and start QGC.