Qgc motor arm spin adjustment

Hi, I’m brand new here and also very new to RC vehicles so I appreciate any answers and patience.

I have a PX4 I’m using it in a 450 quad frame. I have installed firmware and set everything up from qgroundcontrol. Everything works, but when I arm the motors, they spin up fast enought that the quad takes off even with the throttle all the way down. I have calibrated everything and double checked my set up. I’m not sure what else I can do. This happens in both manual and auto level modes.

I have searched for hours to try to find an answer. There seems to be a parameter called MOT_SPIN_ARMED that can be adjusted, but I can not find it anywhere in the parameters in qgc. Can someone explains to me like I’m a 5 year old how to adjust this parameter using qgroundcontrol for Mac? Or perhaps if there’s something else I should try first? I would actually prefer that the motors don’t start to spin when armed, but if I have to live with that at least maybe I could fix the uncontrolled take off and disarm crash landing?

Thanks for your help.

You should see it in the parameter widget. If not use APM Planner 2.0 and go to the Config/Tuning view and select Full Parameter List.

APM Planner 2.0 runs on OS X

Thanks for that response billbonney, the issue I have with APM Planner 2.0 is it doesn’t seem to recognize the firmware installed via qgroundcontrol when I connect. It is like I have plugged in a brand new device, no parameters are available within the app.

APM appears to want me to install a different firmware and set everything up again. I’d rather figure out a way to stop the spinning that doesn’t involve a brand new from scratch setup. If there is a way to get APM to talk to the Pixhawk with the existing set up please advise how to do that.

Thanks again

You have to decide which flight stack you want to run on the Pixhawk HW


If you choose APM you can use APM Planner to install the correct version. Or if you choose PX4 you can use QGC.

MOT_SPIN_ARMED is related to the APM project, so I assumed you where using that flight stack. If you use PX4 they have different behaviour and parameters.

Hope that helps

Again thanks for taking the time to respond.

I installed whatever firmware comes with qgroundcontrol. I chose qgroundcontrol because I’m a newbie and that is what it says to use on pixhawk.org in their quickstart. pixhawk.org/users/first_steps. I followed that guide and everything worked except for the unintended take off at arming. Perhaps it’s another parameter I need to adjust in qgroundcontrol? If so maybe someone could tell me what it is?

I did try loading the APM 2.0 firmware yesterday, but I couldn’t get anything to work after calibrating all the sensors and radio so I went back to the qgroundcontrol setup. wich is working but again has the motor spin up at arm, it seemed like it would be easier to solve the one issue with qgroundcontrol than to try to figure out the 4 other issues that I seemed to encounter with APM.

I guess I should probably just use a Naze 32 controller until I learn more about how these things work. It’s really frustrating to be so close yet have one issue which prevents me moving forward. thanks again for the responses.

You find the support and setup easier for APM, see copter.ardupilot.com/ for the docs and setup.

Good Luck, whichever way you go. :slight_smile:

In the interest of perhaps helping someone else with this issue.

I was never able to figure out how to prevent the motors from spinning or controlling the rate at which they spin when armed using qgroundcontrol. I did install and successfully set up my pixhawk using APM2.0 using info found here copter.ardupilot.com/wiki/initial-setup/

There were several cryptic messages involving compass offset too high but after 4 recalibrations it seems to be functioning.

I needed to do this esc cal http://copter.ardupilot.com/wiki/initial-setup/esc-motor/ as well

Also the two sticky info posts on this forum will give you an idea


INFO: QGroundControl vs APM Planner 2.0 viewtopic.php?f=13&t=10950
INFO: QGroundControl Firmware Installation viewtopic.php?f=13&t=10672