Servers by jDrones

QGC installation missing file

Hi everyone, longtime reader but first post.
After 2 of my Windows 7 Pro laptops quit working this year I’ve tried to install QGC on a Dell laptop running VISTA (yes I know is OLD but it’s all I have left except for Android Tablet).
I’ve downloaded the latest Windows installed and ran it (including all Drivers). It said installation complete.
However it will not start in any of the 3 models. It keeps bringing up a message box saying: Unable to locate component. “api-ms-win-crt-runtime-l1-1-0.dll was not found. Reinstalling application may fix this problem”
I ran install again and selected Repair option, it installed several more times and said successful, but it still won’t start. Get same message.
Is this a .dll from QGC or a Windows file? What package might I find this file and where should it be located?
Thanks
dp

Download and install everything from here except the ‘… For Visual Studio’ packages:

In the long term, you’re going to need to seriously investigate another OS as Vista has long been out of support and 7 just ended support.

If your hardware isn’t completely esoteric and is semi-modern, you’re likely better off switching to a lightweight Linux distribution at this point.

Ok, I’ll give it a try. After 2 fine working laptops with latest QGC just quit working this past year this old laptop is all I have left. No $$$ to go out an buy Newest WIN 10 System (but I’m looking for good used laptop if anyone has available).
I’m running QGC on a new Lenovo T8 Android tablet with very few issues except can’t handle Logs (Logs only available on Desktop) and no motor test pages.
I don’t like Mission Planner but it does seem to run ok on Vista.
Thanks for the help.
dp (still dp even upside down)

Android daily builds should have motor test pages. What logs are you looking for. Android daily will also save telemetry logs.

Also FYI: You may be fighting a losing battle trying to get a new QGC version to run on Windows 7. Latest Windows builds are 64 bit only and likely won’t work on Vista. And if the laptop is that old it may be 32 bit hardware. Also not sure if the newer version of Qt we are using is supported that far back.

1 Like
Servers by jDrones