Servers by jDrones

QGC back compat ArduPilot 4.0+ only

I want to move backward compatibility forward such that QGC only supports 4.0+ versions of firmware. Anyone see any important reason no to do that?

Absolutely there are good reasons. Never remove compatibility unless it’s necessary to do so for some other reason. There are several people I know who are running builds prior to 4.0 (in both Plane and Copter) with QGC.

Could I suggest waiting for the 4.1 round of releases first?

I can understand wanting to remove compat code.

I’m not sure how the QGC ecosystem works in terms of businesses using skinned and otherwise customised versions - do they update for bugfixes or just go with what works-for-them? I’m just a bit worried that ArduPilot Partners might get bitten because they can’t refresh to a more recent version of QGC because all of their vehicles are running Copter 3.6 or something. Now we’d prefer them not to be doing the latter, of course - but Reasons.

1 Like
Servers by jDrones