Qbrain with 3dr iris+ corpse: motor spin issues

Sorry, noob with problems here:
Short version: Iris+ crashed with ESC failing. Now used all other parts on a s500 frame with a qbrain 20A 4in1 ESC to replace the 3dr version.
The issue now is that the quad tips over when trying to take off. When testing the throttles with the quad strapped down, i noticed that some of the engines seem to not get up to the correct speed until the throttle is at about 75%. Then you cannhear them catching up and the quad pulls straight up (tries: it’s strapped down). I have no clue whether it’s the pixhawk or the qbrain and whether it’s settings or whether either of them is broken.
Any ideas? Thnx!

If the QBrain still has the original firmware, you have to do the ESC calibration procedure. Also follow the QBrain guide to set the correct settings for multicopter.

Ah, depending on how you install the QBrain you’ll have to check if the motor order is the one that PixHawk requires, not the numbering on the QBrain.

Thanks for the reply.
Motors are installed as listed in the link and spin in the correct direction. ESC has been calibrated and has no issues when props are not installed. However with props, spinning speed has the issues as mentioned.

Any other thoughts that may help?

Are the props correctly mounted ?? Just picked my props from the quad and they are marked Front Right, Rear Right FR, RR, Front Left, Rear Left, FL, RL

Unfortunately, yes. The advantage of using Iris+ parts, is that everything os color coded and fits in only one way.

You’ll have to get some logs out of the PixHawk to pinpoint where the problem might be.

Before that enable the full logging, setting the parameter LOG_BITMASK to 655358, then do the tests you refer and post here the corresponding log.

Did you solve the problem? I have an Iris+ and I had to change the esc with the qbrain. I did all the configurations and calibrations, but the engines seem not to get the correct speed according to throttle. I am sending 2 log files.
2016-12-11 18-44-53.bin (2.3 MB)
2016-12-11 19-43-02.bin (2.1 MB)

I guess your are aware that you are in AltHold-mode.

Did you check the esc calibration?
You can use Mission Planner -> Initial Setup(Tab) -> Optinal Hardware -> Motor Test
When you turn on all motors at once with for example 5% throttle,. they should all start to spin slowly. At the same time check the direction once again :wink:

oh and:

Can you check the RC calibration for channel 5? It has a strange range(1145-1579)?


Hello patrick and thank you for your response.
I am going to check all that you wrote once again and I hope that I am going to find the solution soon.
One more think that I would like to ask is do I have to flash BLheli to qbrain?
Thank you

Hey Dimitris
I don’t have any experience with qbrain esc’s but they are made specificly for quadcopters. They should be working without software mods, but it’s always a good idea to check the manual for different setups.

With BLHeli you get a lot of new parameters which isn’t always a good thing.