Q_Options missing in 4.10dev?

Doing a somewhat experimental tricopter/plane and was looking to take advantage of some of the new Q_options in 4.10dev, but they are not showing up in mission planner after uploading the 4.10 firmware.
I’ve confirmed that the correct firmware is uploaded, what else am I missing?

Q_Enable to 1 and refresh parameters is a good start…

Yeah, Q_enable is 1 and I can see the old Q_option values. Restarted mission planner, FC, etc.

I’ll try setting Q_Enable flipping to 0 and back.

Tried on an spare (retired) pixhawk1. Had Copter on it,. flashed it with Arduplane 4.10dev.
Q_Enable = 1 and I only get the first 5 options. I’m mostly interested in Force QAssist and I can set the value manually to 128 in QGroundcontrol, but mission planner wont let me, so I’m not sure if it should show up in the Bitmask UI thing.

Ctrt + f menu then Param gen. This will grab the latest set of param descriptions.

1 Like

Yeah, something else is going on:
To grab the 4.10 dev, I go
Install firmware ->
all options (at the bottom)
When the menu pops up, I go:
Version 4.10

If I grab it from firmware.ardupilot, I get same result.

I have a Pixhawk1-1M in the junk drawer and when I load 4.1.0-dev and enable the Q options I see all of them. Parameter file attached for reference.
Q params.param (18.4 KB)

And you get all the bit options in Q_options? (it’s still set to 0 in your parameter file).

Q_ENABLE is set to 1

Just making sure we’re talking about the same thing:
I’m talking about this:

I have the Q_enable =1 and get all the Q_xxxx options.
What I don’t get , is the full list of bit selections in Q_OPTIONS
I want to enable force_assist (bit 7), which is not available in UI

This? It’s a Bitmask man.

Yeah, those. I’m only getting the first 5. What version of MP are you using?

The one I always use which is usually a fresh daily update check of Beta. If something isn’t shown or a menu is greyed out or others are claiming feature or parameters that you don’t see hit the “Check for Beta Updates” button. Required if you are running a Dev version, make a habit of it.

1 Like

Bingo!. Getting latest beta MP sorted it. Thanks for the help.!