Px4io-v2.bin has error after programming

I’m trying to learn more and more about building the complete system. To that end I wired up a background debugger and I pulled the memory out of both the F1 (px4io) and the F4(px4fmu) processors into flat binary files. I then erased the processors, verified that nothing happened on power up, and then re-wrote out the flat images I stored. Everything still works, so sanity is established.

I then tried to write the px4io-v2.bin file that is created in the Arduplane build process out to the F1 processor and I get “Check BRD_TYPE px4io failed to start” I switched BRD_TYPE to ‘2’ since that is what I was using before, rebooted, and still get the message. As soon as I put the binary I read off back everything is kosher.

As a note I was also able to program the fmu_bl.bin from deep in the directory structure into the F4 and use mission planned to load in the ArduPlane-v2.px4 file I built. So I think I have the F4 pretty well wired, what am I missing on px4io?


I’m almost sure that the px4io-v2.bin file is just the firmware, doesn’t include the bootloader, that’s why it won’t load.

So say I got a brand new piece of hardware from any of these random manufactures, and it had absolutely nothing programmed? How do I program it from the source repository?

You either build the bootloader for PX4IO from source (https://github.com/ArduPilot/Bootloader) or use our built version (https://github.com/ArduPilot/ardupilot/tree/master/mk/PX4/bootloader) and then program the F1.

1 Like

Same problem

Setting BRD_IO_ENABLE = 0

solved the problem so in my case I guess there was an hardware failure of the co processor or other component.
If I have understood well my Pixhawk is now a kind of Pixracer.

1 Like

SOLVED! Thank you lucamax