PX4FLOW spikes on data output

I think it wasn’t the problem. I was able to run the arducopter 3.6-dev now, however optical flow still not functioning correctly.btw, do you know where I can find the launch file of the gcs bridge in erle? I need to setup gcs id for override purposes


If you’re using “frambuesa” OS, you can found the launch file under /opt/ros/kinetic folder. If you’re using the “escarlata”, the path is /home/erle/ros_ws.



1 Like

Hey @LanderU , thanks for coming in :slight_smile:
Gentlemen, I was getting suspicious , so I decided to give it a try.
So I installed my HomeBrew PXF MINI cape

On a RPI 2B and compiled the latest master and connected my Px4Flow & Lidar Lite V3.
did sudo ./arducopter -C udp:my.ground.station.pc:14550 and opened Mission Planner
I enabled the optical flow and the range finder as type 15.

Rebooted and voilà , optical flow signal and rangefinder signal :


Good to know px4flow can be used! I am getting super jealous. Maybe I should try it with Mission Planner instead. Did you also connected them on different I2C buses?

Yes you should Use Mission planner in this particular case.
I just have one I2C bus so both sensors are connected using the DIY Hub as shown in previous pictures.

I suspect that your Px4Flow might not flashed with the correct firmware.

I flashed it with the firmware I got from qgroudncontrol. Which version are you using?

This one

The first step:
Download and unzip the PX4Flow-KLT firmware https://github.com/priseborough/px4flow/tree/klt_flow

1 Like

I have lots of communication issue with mission planner in general. However, with the previously flashed firmware from qgroundcontrol I was able to read images from the mission planner.

I am losing faith. Maybe this is a issue with I2C bus on raps pi 3? Or something with erle firmware? As far as I know, no erle user has bought px4flow to work… Maybe not a coincidence.

Well, if you have uploaded the correct firmware on the Px4Flow and still canoot read the signal on Mission Planner , @LanderU will have to either fix it or ship me an ErleBrain :wink:

I guess so… thanks for the support anyways!

The USB port works fine for the px4flow, and I receive meaningful ROS messages. Is there a way to feed this information to ardupilot’s optical flow read? I am not afraid to compile something from source.

I really need to get my project to work :smirk:


are you using the latest master?



Hi @LanderU

I tried first with the latest master 3.6dev and it is giving one constant value.( And it didn’t work well with APM planner 2.0.25rc)
I was at 3.4rc2(the version erle is usually on) when I observe the spikes.

However I also need a higher version then this for my lidarlite v3 to work, so my next plan is to test 3.5rc7.

Hi @ppoirier,

are you using the current master?



Quite sure he did :slight_smile: Although I didn’t use Mission Planner. But both Qgroundcontrol and APM shows I am reading constant value

Yes ,I just cloned master , waf configure with erlebrain2 and waf copter

@LanderU thanks for the update
@JD-ETH I think I might have the answer why Px4Flow does not work with GCS

1 Like

Aha that must be it! … I didn’t clearly understand what was decided in the dev call though — Should I attempt to flash back a older version of firmware?

The Px4Flow code http://ardupilot.org/copter/docs/common-px4flow-overview.html#upgrade-the-px4flow-sensor-s-firmware4 is the only version that is compatible with APM. What @rmackay9 will do is to pull Paul’s branch into the ardupilot github area and then change the reported id from the flow sensor so the GCSs are happier.

So, until this is done and tested, the only method that works for testing and configuring the Px4Flow is using Mission Planner.


As long as I can use it in APM I’m happy! I will downgrade the firmware then.

If I understood correctly, the only way to fuse the px4flow data into ardupilot is using that specific firmware version? Or it is just not shown on the apm planner?

I will be happy to see the new firmware working too in the future. Great, thanks!