PX4 - Check BRD_TYPE: Baro: unable to initialise driver

Hello, I am a teacher trying to help a student build a Quadcopter. We are both noobs to this so any guidance is really appreciated.

He is using:
Readytosky Pixhawk PX4 Flight Controller Pix 2.4.8 32 Bit Flight Control Board+4GB SD Card
FLYSKY FS-i6X 10CH 2.4GHz RC Transmitter Controller/W iA10B Receiver
Mission Planner 1.3.9 on a PC Running Windows 10

Everything was working fine last week before he connected to the power and motors; but this week we are not getting any telemetry data or able to view radio data in Mission Planner. We are also having some problems with updating firmware.

When we connect the Pixwawk to Mission Planner, we get this error:
Check BRD_TYPE: Baro: unable to initialise driver

I tried refreshing the firmware by putting on ArduPlane and then ArduCopter but we get some error messages like this:

This is what the lights look like on the Pixhawk:

I checked that the correct BRD_TYPE was selected. It is Pixhawk
We disconnected the power and motors and we have the same issues.
We tried changing the USB cable. Same.
Tried a different computer running APM Planner 2.0 but had the same issues.

Any ideas or suggestions?