Px4 2.4.8 + ESC F40 MAMBA wobbling shaking

My drone extremely shaking/wobbling on taking off. Setup: 5" frame, motors 2306 + props 5143 + ESC MAMBA F40, FC is mounted on soft mount rubber, even of flight mode (acro, loiter, stabilize) it shakes. Did the calibration (here is the sound esc calib - YouTube), compass & imu calibration too.
20211112 172029 - YouTube

You need to follow the Tuning Process Instructions — Copter documentation step-by-step without skipping any step.

After that you should tune the dynamic notch filter.

1 Like

Thank You for Your reply. I’ve read this manual but it still wobbling, reducing by 50% values reach the lower values

also I had to stop autotune mode after 3 mins because the motors were too hot

Post a link to a .bin flight log.

here are last logs of test with lover values of PID than default
2021-11-13 23-22-58.bin (612.3 KB)
2021-11-13 23-34-14.bin (526 KB)
2021-11-13 23-40-00.bin (491.5 KB)
rest params:
R_MAX 160000
Y_MAX 35000

Why are you running such an old version of Arducopter? Nuttx no less! Update to latest stable 4.1.1.

I would suggest resetting all to default (start over), then run the Alt>A Initial Tuning plug-in in Mission Planner. Update Mission Planner to latest Beta 1st from the Help screen.

Then make another short hover flight and post that log.

I’m surprised you didn’t ask “What is a Dynamic Notch Filter”? :grinning:

BTW-The correct firmware target for that Flight Controller is Pixhawk1

1 Like


Here’s my setup flow:

  1. reset all params to default
  2. calibrate compass, IMU, RC axis, ESC, did motor test.
  3. alt + a as a begin initial tuning, the values are similar like my previous settings did manually:new values
  4. arm + flight in althold and here’s the log file from very short flight:2021-11-14 12-09-53.bin (352 KB)

I wont able arm on 4.1.1 since it gives me an error “pitch rc2 is not neutral”, moving back to 4.0.3 (I dont know why 4.0.7 disappear from previous firmware list) flies without this message. I’m still on nuttx - my previous 12 drones flies perfectly, IMHO moving into ChibiOS doesnt affect on my vibrate problem.

No, you are now on Chibios where you should be. Update to V4.1.1 and fix the problems with arming. Set the PWM_TYPE to Dshot600 it will likely be more reliable.
Then you can try decreasing the rate pitch and roll PID’s by half. Once you have stable flight, configure the Dynamic Notch filter from the Wiki.

1 Like

Sorry, I’ve switched onto ChibiOS, you’re right
Setting into DSHOT600 and reduce ATC_ANG_PIT_P & ATC_ANG_RLL_P to 3 (minimum acceptable) from 4.5 helped a lot but it is very far away from ideal 5" drone like on betaflight.
log:2021-11-14 21-20-28.bin (540 KB)
then I’ve reduce by half rate PID of roll and pitch and it much much better but not ideal.

2021-11-14 21-52-02.bin (924 KB)

Do You know setting params need to be rebooted or maybe I can change it during flight? To make it faster I’ve managed wireless connection throught TELEM1 via esp8266 module

These are way too low:
You should configure the Dynamic Notch filter. RPM from ESC telemetry would be the best reference if it’s available on those ESC’s. If not throttle reference works well.
Set these based on the tuning guide:

You can use In-flight tuning on a chan6 configured pot from your transmitter. You would have seen this in the Tuning guide:
Transmitter based tuning

1 Like