Put HUD window back in MP without restart

Ok, I’m either missing something trivial or it is not possible. Whenever I pop the HUD window out of MP, I cannot get the HUD back into MP unless I restart MP. In my case, it’s almost always accidental when I pop the HUD out and it’s really inconvenient if I am already in-flight to have to close MP and lose telemetry connection and have to restart my HUD AVI recording.
Is there a way to pop the HUD back into MP without restarting?

have you tried to close the hud

Yes, closing the HUD closes the window and it does not snap back into MP. The only way I see to get it back is to restart MP.

Try reinstalling it because closing the hud should snap it back in position.

@Corrado_Steri It’s happened on multiple different machines. Since I started using Mission Planner 3+ yrs ago. Have you tried to do it? I just installed on brand new laptop the latest version and still same behavior.

Mine snaps back in position when i close it, both on windows and linux machine.

Not for me. 2 different computers, Windows 10, and Windows 11. GTX1050 and Intel 620 graphics cards.

Is it updated to latest beta?

No I’m running latest stable.

try updating it, maybe it’ll solve your issue.

Just updated to build 1.3.7955.38681. Same result.

Clarification: If I have the HUD in the main window (this is how I always fly) with the map in top left, the behavior after double clicking the hud and clicking X results in the HUD disappearing.

If I swap HUD with map and HUD is now on the top left side and I double click HUD, the HUD window dropout comes out of MP. When I click X the window snaps back into the position in MP.

So seems the behavior is when HUD is on right side.

Yes if you swap position than it doesn’t snap in place, maybe @Michael_Oborne can help here.

1 Like

@Ed_209 It is not super obvious, but if you drag the vertical separator between the windows the HUD will reappear

1 Like

@CraigElder Thanks, that actually prevents me from having to restart MP. It’s quirky until you click swap with map to get it back over but it works nonetheless.

update to latest beta, yes its a bug.

Thank you @Michael_Oborne works like a charm now!