Pulsedlight on pixhawk 3.3rc5

Hello all.
Just received my pulsedlight mini yesterday, got it installed on my Pixhawk controlled 680pro last night. Followed the wiki, used the PWM, not the I2C, but I noticed there’s a descripency with the instructions.
It first says use range finder type ‘5’, than later it says to use type ‘4’.
Using type 5 works as in I can see information being populated and updated in sonarrange and sonarvoltage, so apparently is working and fairly accurate, but I get a prearm warning, “check rangefinder”, and pixhawk fails the prearm test and will not arm with safety switch. Wiki states I can turn off prearm test “parameters/sonar”. I cannot locate the parameters/sonar, I have just “parameters”, and when I turn off prearm test “check parameters”, pixhawk passes the prearm tests, and can then arm via safety switch. I have a rack that the lidar ‘sees’ through, so while sitting on my workbench, lidar is showing 0.54 in sonarrange, so it passes the distance requirements it seems.
If I use type 4, pixhawk passes prearm tests no problem, but no information in sonarrange nor sonarvoltage, so it seems pixhawk is not accepting the information from lidar. If I have to disable the prearm test, I’d like to be specific, as in parameters/sonar, not just parameters.
Other than that, seems to work.
Also, I used a 500 ohm resistor, and using beta version of mission planner, build 1.1.5632.31781. Going to conduct some test flights today after work. Wish me luck…

Update on today’s test flight in one word: Awesome…
TARA (680pro hex, my young girls always name my RC stuff girls names, lol.) Armed up right away, took her to about 12 feet, hit althold and let wind drift her over my van( I live in central Florida, so not many elevation changes here), she got over van and went up right away, then upon clearing the van, dropped back to same height. Then set to loiter, flew over some buildings, but at 90’, same result, worked great.
Best thing though, I set her at about 3 feet agl, and flew around various patterns, it was like she was on a stand hovering around, no variations. Even when circle mode was engaged, all the while in a 12-15k wind, flew perfect.
And I didn’t have to raise TARA up 50cm minimum, just placed on the ground, powered up, connected tablet, armed via safety switch, armed then flew.
Now i just need bigger batteries, thinking 10000’s. Im running 4s/ 14.8, any recommendations?


Your info is interesting but a reference to your “PulseLightMini” could be usefull. Without any product information, no way to help or do a search.





Was flying yesterday, connected to laptop instead of my tablet, and got bad LIDAR couple of times on screen, but was working great from how she was flying. Weird. FYI.

I’m using a Lidarlite with the same results. Works great, but get the bad lidar health. Setup on PWM as well.

Mine works good, alittle too good, lol.
Was taking video of my girls birthday party last week, had it locked in loiter at 25’ or so, taking different shots, and it would pop up 4 feet or so apparently randomly (party was in backyard, I was in the front), moved camera to look down, and kids were running under laughing and playing in the prop down wash, and when one would walk under, the lidar would see them and go up, then right back down. Lol.

I have a Lidar-Lite, which I am setting up on a Pixhawk. as above the Wiki states to set RNGFND_TYPE to 5.
When I do this and save this setting, When checking the sonar readings, all I get is zeros. going back into the setting I find that RNGFND_TYPE has changed back to 4.
Is the Wiki wrong, or why does the setting change. All other setting stay as set. I’m using beta 3.3rc7 Quad firmware :confused:

Mine did the same thing. Set it to 4, works well.

Hi Ducatiracer,
My Lidar-lite turned out to be faulty. I had it replaced, and it works fine now.
Do you have it mounted on a Quad? If so is it near the front, so it can see raised objects, before it hits them, or near the centre, to get a better reading?

Mounted just behind my gimble mount, in front of the battery. Got it angled slightly forward, just a few degrees. Works great, even over the ocean, would start to rise up when a wave went by, by I did notice that there’s a .5 or so lag on new height vs altitude increase.

How are you guys calibrating the sensor when using PWM hook up? WhenI had it hooked up via I2C it was dead on accurate. With the PWM Output and Volts per meter set to 1 it reads about .3 meters off from a height of .8m and gets worse over longer distances.

If I set the volts per meter to .8 it is dead on accurate at 1m and less, but, at long distances it is a bit short. I am thinking somewhere between .8 and .9v per meter is the correct offset, but, not sure if this is the correct way to adjust for the voltage offset.

How are you supposed to calibrate it?

I didn’t calibrate it. I just use it to lock in the AGL. whether its 30’ and it senses 30’ or 40’, as long as it stays locked in at that AGL.
I do know when its on a wire mesh stand on my work bench, approximately 34cm, lidar reports 0.3m.