Servers by jDrones

Problems with integrating RTK with Pixhawk4

Hello everyone,

I am struggling a little bit with integrating my RTK with Pixhawk4. Currently, I am continuing a project from students who worked on it for the last year. Therefore I am not sure which things I can change without messing up the software. From the following manual (https://docs.emlid.com/reach/ardupilot-integration/) it became clear how I can integrate the RTK module with Pixhawk. However, I cannot find the parameter “GPS_TYPE2” on my Pixhawk software. This parameter allows a 2nd GPS module on the Pixhawk. I tried finding the parameter via Qcontrol and Mission Planner but both did not give me this parameter. I tried implementing the full parameter list from (https://ardupilot.org/plane/docs/parameters-Plane-stable-V3.9.10.html) but I did not know how I can do this. However there are multiple parameters missing from my RTK.

After searching a little bit further I found a list of the exact parameters which were listed inside Mission Planner which can be found here: https://hamishwillee.gitbooks.io/ham_px4userguide/content/en/advanced_config/parameter_reference.html .

I am wondering if the wrong set of parameters is implemented into my Pixhawk or if an other type of software is used inside this Pixhawk. I am struggling for over a week now and I really want this to work. Could someone help me out?

Which FW version are you using? Try updating to the latest stable version.
firmware.ardupilot.org

Thank you for your reply. I am not sure which version I use. I dont even know if i am using a copter, plane or other firmware. However, the callibration process of the parameters is done by other colleages and these values are still saved.
Will these values disapear when I switch to a new or another version? And if so, how can I retrieve those values?

How are you sure that you connect to the FW? where are you looking at the parameter?

You can retrieve current parameter values and save to a file. But if you update the FW you can only go back if you have the FW file and the parameter file

Okay, i am looking in CONFIG in mission planner to see the parameters. Do you know how I can get the firmware file?

Your colleagues students are the only persons that can tell you how they build the FW (assuming they costumed it). If it a non customized firmware, then it is available from firmware.ardupilot.org

I think you should read the ardupilot wiki instead of the emlid wiki to find out a bit more about the FW. And use an updated Mission Planner to make sure you get the latest fixes.

I installed the new plane 4.0.6 FW and this solved the parameter problem. The problem uploading the “customized” code for data logging, the firmware is deleted and an arbitrary firmware is installed (with these parameters: https://hamishwillee.gitbooks.io/ham_px4userguide/content/en/advanced_config/parameter_reference.html). This probably means that I need to save the parameters of the plane 4.0.6 FW in a separate file and load it into the PX4 after I have loaded the data logging file from my colleague students.

I will try this and post the end result as soon as I have them. Thank you so much for your help!

Servers by jDrones