Problems with Initial Mode "Auto" ,instead goes to Hold

I’m hoping to get some help with the following problem. The idea is to tow a floating platform with a skidsteer setup some where on to the lake, then to initialize the autopilot so that it goes straight into LOITER at this point. My initial approach is to have a Start/STop Switch Set-up, so that when you hit the switch it performs a “Mission” which basically consists of 10 seconds of HOLD and then going into LOITER UNLIMITED. see:
When we want to re-locate the platform we would like to hit the switch again (motors stop) and we can tow it somewhere else.
Somehow I can’t seem to initialize the Autopilot in AUTO (even though the INITIAL_MODE is set to 10) and I suspect it has something to do with the loaded Mission.
Can anyone help? thanks

You now have 3 threads going with the same issue.

I have been playing around with this on the bench and I cannot get it to initialize in Auto Mode with the INITIAL_MODE parameter set to Auto (10). “Uknown” mode is shown in the Mission Planner HUD and Flight Mode 16 is shown in the log.Other modes do work with this parameter. Without this working you cannot do what you want w/o an RC system.

Maybe @rmackay9 can take a peek.

thanks for going through the whole process as well. I tried various combos today , but it never worked…
It always started up in HOLD.
When I would change to AUTO, the mission would immediately start (not wait on the Start/Stop button to be switched).
I then decided to start up the AP without it being connected to MP. Went through the routine of engaging the Start/Stop Button etc.
Afterwards downloaded the log file to check if it had completed the mission. But this was not the case
My thinking was that maybe it would actually do the mission if it werent connected to MP…
Hopefully rmackay has a way forward… thanks

So I got my Rover out to try as other efforts were on a bench FC and the same thing. I set it for no arming required so it’s ready on boot with RC system off, and enabled Auto Kickstart (no switch and I know this works). It starts up in mode “unkown” I’m sure despite Auto being set and the Mission will not start from this condition. No GCS was connected. If I then turn on the RC radio and switch to Auto and give it a kick it will start. The basic problem seems to be INITIAL_MODE parameter not recognizing Auto. I have run out of ideas to try for the moment…

Hey Dave
I did send rmackay another message and waiting to hear back from him. I don’t really want to bug him too much… :wink: Maybe its worth re-installing older versions of ArduRover? what version are you running?

Current Stable 4.0.0.

Still no solution to this Auto_Trigger problem. Could @rmackay9 take a look please? It could be a ArduRover 4.0 problem?

This would seem to be a problem with Rover. I just tested it on an FC running Plane and it will start in Auto with INITIAL_MODE set to Auto (10) on boot.