Problems with enabling LTTNG feature on Ardupilot

Hello everyone,

I am trying to integrate LTTNG feature on the Ardupilot and followed this link https://github.com/jberaud/ardupilot/commit/4bd763d58a6b529630629ad581de198f9d6e6731. However, I am still struggling to install the armhf version of liblttng-ust on AMD64 ubuntu machine, as some of the dependencies do not match. Please kindly suggest. Thank you.

" liblttng-ust-ctl2:armhf : Depends: libc6:armhf (>= 2.15) but it is not going to be installed
liblttng-ust-python-agent0:armhf : Depends: libc6:armhf (>= 2.4) but it is not going to be installed
Depends: liblttng-ust0:armhf (= 2.9.0-1~xenial1) but it is not going to be installed
Depends: liburcu4:armhf (>= 0.9.1) but it is not going to be installed
liburcu-dev:armhf : Depends: liburcu4:armhf (= 0.9.3-1~xenial1) but it is not going to be installed
uuid-dev:armhf : Depends: libc6-dev:armhf but it is not going to be installed or
libc-dev:armhf
Depends: libuuid1:armhf (= 2.27.1-6ubuntu3) but it is not going to be installed
"

Regards,
Eric