Problems with adding maps to the mission planner


I sign in to the forum cause I have a problem with inserting geo referenced maps to my mission planner.
Without signing I read some of the posts here in the forum, most of them were quite helpful, everytime I thought finding the problem, but then there were another one…

What I have: I have a georeferenced map in WGS84 made in QGIS (.tiff) also a tile version of this map in .png and .jpeg.
Cause the area I plan to fligh is a long distance away and I plan to do it in vacation I could not test, if the maps work without any internet recieving (right?).

What I tried up to now:

  1. I make the systemfolders visible and insert my .tiff map into the folder. than restarting mission planner and looked into the window with the code. the maps were loaded. But while zooming into the area (flight plan) I want to fly without any internet connection, my card will not be placed. So second try…

  2. After converting the .tiff into a tile via QGIS, I want to try another way. I placed the tile in the gmapchache changed the map through pressing control + F (i think) and set the loading path in the folder i want.
    But without internet, I could not see the map in my flight plan.

  3. I restartet the internet connection and prefetch the area. So I should have the card offline.

So my questions are:

  1. I have to use the costoum map choice in the flight plan?
  2. Do you have an idea, how I get my map into MP?
  3. Am I able to test my map before the vacation?
  4. Thanks for your help :slight_smile:

Sorry for the long text and my bad english :slight_smile:
Hopefully one of you can help me!
best regards

1 Like

Do you have a custom tile set for every zoom level you want to use?

Thanks for your answer.

Yes I have the tile in 17 zoom levels.
So with the custom selection in the map source it should work, shouldn’t?


Magnus, You have not explained what does happen, or not happen, with your tests?

Did you compare the naming convention for your map zoom level subdirectories to ones created by pre-fetching maps with Mission Planner?

Not considering custom map tiles you certainly can pre-fetch maps and it does work. I have found that some maps providers will block you if you try and download too many maps at the same session.

yes I have compared them, they are following the same convention, but didn’t have the same names…

I will try it with less zoom levels.

What do you exactly mean with “happen with test”?
I Thought, when the maps are loaded, the area will automaticly shown in the flight planner… and my own GPS signal could be another one.

Thanks for your help

Just describe what happened. Did you get an image at all? Do the google maps work? Pre-fetched google maps work.

You might change the names of the top level zoom directories and see if you can then display the maps.

where are you putting the file? SRTM data is the only hidden folder, you need to use GDAL for custom images. not SRTM, which is elevation data.

Thanks for your answers.

I checked the names of the zoom levels and everything, they are fine.
Putting the .tiff in the gdal/data didn’t helped me, also if I tried it with my tile dataset.
If selecting custom in the flight plan, the status says loaded tiles, it shows the coordinates my picture represent, but didnt show the picture itself. On the right side of my height the word “Ocean” is written.
Iam a bit confused.

My prefeched map from the area works well. In contrast to my own created maps :frowning:

In the GDALdirectory also a .tiff should be loaded?

Sorry for the trouble.

I will yield to Michael who is the expert but I don’t think it will work with tiff tiles they need to be jpg.

hi its me again,
the tiles were in the .png format, thats was one problem.
where in the gdal directory do you place the tiles?
I tried it with the data-subfolder. after all I insert the 14 subfolders of my tile-Zoomlevels and focused them by cntrl +F and the “insert GE”.
as coordinates, mp calls invalid and the picture weren’t found by myself?! :((

do you have an idea, or find my mistake?