Problems connecting to Nexus 7 2013

Hello, a new Android member :smiley: . I have a new Nexus7 2013 with 4.3 Android, I try to connect with a Rmodem via Usb OTG, the led stays green but when I choose connect, nothing happens, perhaps something with usb disable because I try to connect a pendrive and it not recognize too. Thank’s for your help.

If it’s not able to recognize the pen-drive the problem most likely lies on the USB adapter.

Also when you connect the device the tablet should pop a window asking if you want to use DroidPlanner with the thing you just pluged into USB.

I have a Nexus 7 2013, when I plug in the USB OTG cable (with the 3DR telemetry radio already plugged into it) Droidplanner automatically launches and works great.

Here is a link to the 3DR telemetry kit I have:
https://store.3drobotics.com/products/3dr-radio-telemetry-kit-915-mhz

I tried connecting a clone telemetry radio kit and nothing happened. Can’t remember if it was a HK or RCTimer clone.

@bisenberger
With some effort we probably can make the clone radios work also.

Thank’s for your answers I’m going to check with another one

Hi!

As said on DIY forum, I cannot manage to connect my Nexus 7 2013 with my telemetry. When the ground module is connected to my tablet with the OTG, green light is fixed, and red flashes (normal). But on the tablet I have got no propmt for anything. If I manually start Droidplanner I cannot connect my ground to air module. With a USB flash disk, I can mount it with StickMount Software on my tablet but I never have a popup window with it neither.

Tablet: Nexus 7 2013 rooted (but there might be an option I didn’t correctly checked by rooting)
Droidplanner version: 1.2.0
APM board: MultiWii Pro Flight Controller w/MTK GPS Module with ArduPlaneNG
Air & Ground Module: 433MHz from rctimer

Thank you for your support

Hello sirglider, thanks for posting here with more details.

I have in fact tested with a very similar setup:

  • Nexus 7 (2013) - rooted (I also tested with it factory standard without problems)
  • APM 2.5
  • RC timer radios

The fact that you don’t get a command prompt leads me to believe that your USB cable is problematic, but since you can access a flash drive contents that’s not the case.

It’s a very odd situation, are you able to post an Android LOGCAT for me to analyse?

Can you run Andropilot (from Kevin)? So we can rule out a hardware problem.

Finally I solved the problem installing Nexus photo viewer, go to help and follow the instructions to read a pendrive, then try to connect the Rmodem again but, first open the androplanner and then connect the otg cable with the Rmodem, it’s work for me :slight_smile:, thank Arthur great job :smiley:

@sirglider

DroidPlanner works also fine on my Nexus 7 2013.
But I would like to root myself my Nexus7. Could you please provide some details how to do this? Some tested links would be welcome. Do you need to reinstall all of your apps after doing the “root”?

@criro1999

Here is the guide I used. It worked without problems, but I had to reinstall everything.

youtube.com/watch?v=XM3CBtAaoWU

Which are the principal advantages of rooting the nexus?

@cala2

For me the only reason so far is that I can program and debug my app via wifi.

That means no USB cable switching between the pc and telemetry board.

After hours of work I’ve finally figured out how to make the USB OTG cable work with a Nexus 7 2013 without having to root and instal custom rom. the trick is to enable developer mode and thats it …it worked like a champ after that. goto about tablet under settings, at the bottom of the list click Build number 7-8 times then it will say you are now a developer and viola! now when i plug in the usb otg cable with a 3dr radio “I’m using a HK radio clone” it pops up askin you if you want to open droidplanner or andropilot!! I fought with this for over 8 hours today and almost rooted my device over this issue!!

You mean the issue you are having with your hardware. Using free software in a system that would almost have been a work of fiction ten years ago.

@neuro
That’s very odd and you shouldn’t need enable the developer options to use DroidPlanner. Can you just confirm that you are using the Google Play apk?

Thank’s Arthur
I see that only changing the language to English (united states), turn off the tablet and them turn on, the RModem works:)
¿anyone try to connect an external gps via USB to Nexus 7?

@cala2 you’ve got it!
I have rooted my Nexus to solve, but nothing changed. I tried many things but always when I plugged any device never a popup came to the screen asking what to do with it. And then I switch my tablet language from French to English United States and it works!!
@Arthur I’m understand pretty well english to live with my tablet in english, but if you could fix that language bug, that would be great!
Thank you all for support! I go to the field :stuck_out_tongue:

@sirglider
It’s an odd problem, but if you post it at the github issue tracker I’ll try to solve it in the future (right now I’m busy doing other things, like a cool new UI).
github.com/arthurbenemann/droid … state=open

@arthur , the software was working fine but the USB OTG was not working until i enabled developer mode , i had power and the radios were connecting but the tablet and droidplanner were not able to see the 3dr radios until i enabled developer mode its a fix for the issue some people are having with making the nexus 7 see the usb radio

@neuro
Thanks for the reply, I’ll try to investigate that further if I can reproduce the problem.