Problem with telemetry configuration with mission planner

Hi all,

I’m new in the world of ardu FC and i have troubles configurating my telemetry with mission planner. Actually i downloaded the pilots of my radio and it is well recognized by my computer (windows10). But when i try to connect my pixhawk with my computer using the telemetry i have the message below:

1516906030-capture.png - envoi d'image avec NoelShack

Here is the translation for non french speaking people:

“Speed of the radio is limited to 12405.
Parameters name: baud rate”

So i tried different baud rates below 12405 but none of them worked. Any idea to solve my problem please?

Standard telemetry radios, the original 3DR, operated at 57.6K so if you are using something different you need to post some specifics of the telemetry radios you are trying to use.

well i received a telemtry radio included in this pack if it can help …

Those are not like the ones I have. In general these are called/search by SIK radio. You should be able to use a utility to connect to them and make sure the features are setup correctly. Look on the optional hardware tab of Mission Planner.