Servers by jDrones

Problem with Running HITL Simulation Using Flightgear

Hello everyone.

So I have been trying to run HIL simulation using Flightgear and so far I have had no luck. I tried following this tutorial https://ardupilot.org/dev/docs/flightgear-hardware-in-the-loop-simulation.html

But it seems that this tutorial is over 7 years old and its not working.

Does anybody know how can I run HIL using Flightgear?

Hi I actually do some development on FlightGear. You may want to check your version. If I remember correctly you may need an older version of FG (like fg2.4) But so far 2020.1.3 is the way to go < if you don’t have it maybe try it on this version. We also have a large Discord server which other developers could possibly help too. :slight_smile:

I have tried a lot of things and I was unsuccessful in running HIL using flightgear. Can you guide me what repository to use and how can I run it successfully? I have looked everywhere and the videos or blogs that I found were all 7 to 10 years old and none of them is working.

Well I am not familiar with HIL simulation within FG but:
https://flightgear.en.uptodown.com/windows/download/54129 this is FG 2.12.1 which may run the HIL
I don’t see any support after FG 2.X so your best bet would be using that version.

https://discord.gg/r2HJZ7X Some of us may be able to help further in the Official FlightGear server (Only if you want to)

I will join the discord group and see if I can find any help. Thank you so much for your help and for the link. I will surely ask in the group.

1 Like

The issue is not with FlightGear - I have been using it’s versions ranging from 2013-2020 with success for SITL.

The issue is that ArduPilot stopped supporting HIL due to bandwidth and latency issues. So to use HIL you would have to downgrade ArduPilot for a version from a few years back.

Why do you want to run HITL as opposed to SITL?

Hey @Albcem

Thank you for taking out time to respond. There is no problem in running SITL with Flightgear. I have done it using both ArduPilot and PX4. The reason for HITL is I want to test the hardware that I will be using on our fixed wing model. For that, HITL is a must. I was able to run HITL using Gazebo as well, however, since the model support flightgear only, its hard to import it on gazebo.

Can you tell me which Ardupilot version to use? I tried this version https://diydrones.com/profiles/blogs/hardware-in-the-loop-simulation-with-ardupilot-flightgear-and-1

But found no luck.

Servers by jDrones