Problem with Pixhawk 2.4.8 + 6M gps New

Hello, I wanted to share my problem, and today I installed a pixhawk 2.4.8 + 6m GPS with the latest version of fimeware 3.5.4 for my pixhawk, but when I configured everything and in full flight or connected to mission planner when I change flight mode From Stabilize to Loiter or another flight mode does not change.

if I am on the floor active mode loiter and detachment does not let take off stays on the ground.

when I start the manual takeoff if it takes off, once in the air I change from tower or from station configured correctly to loiter mode or another mode and I can not get it to change why this happens?

and tried to use other versions of fimeware but the same result, another pixhaw, another gps, some command to activate the gps ?? something new ??

I am not positive but I don’t think that flight controller will work on 3.5
You need a more current Flight controller
Someone correct me if I am wrong

I think you do not have the HDOP below 2.0

enough GPS coverage that’s why he does not let you change flight

if not correct me some PRO


today it just fell and shattered part of the drone because it collapsed alone, assembled engines in manual despege, went up to 5 meters all right and suddenly the drone only ascended and descended only until I had to land alone and buahhhhhhhh