Problem with 'Moving Base' and 'Follow Me'

Hi,

when I connect a GNSS to my laptop that sends NMEA messages I can see how it works in VisualGPSView:

Connected to a hexa running 3.5.0 rc7, trying to setup ‘Moving Base’ in MP 1.3.43 with the same COM port settings doesn’t show anything on the Flight Data screen map or on the Moving Base screen (same thing with Follow Me screen).
Is this a bug or what am I missing ?

Hi,

@Michael_Oborne I tried another laptop that has u-center installed. COM 7 is the virtual u-blox driver. When I try to connect with COM 7 on the ‘Moving Base’ screen I get this error:

please use the legacy ublox VCP driver. the new one just breaks things.

as for you nmea gps. are you sure its outputting nmea?

In the moment there is a choice between:

  1. u-blox GNSS Standard Driver for Windows, v1.2.0.8
  2. u-blox GNSS Sensor Device Driver for Windows, v2.33
  3. u-blox GNSS VCP Device Driver for Windows, v3.03
    I cannot find a legacy VCP driver on their site, do you have one or can you please tell me where to get it ?

Yes, u-center shows the NMEA messages and as you can see in post #1 the VisualGPSView (uses NMEA) works as well.

use that one…

I have tried all the listed drivers - none of them works for me :sob:.
According to the u-blox GNSS VCP Device Driver for Windows, v3.03 Release Notes:
4.1 Known Issues
• This driver does not fully emulate a hardware serial port.
• The .Net ‘SerialPort’ class does not recognise the COM port created by this driver as real COM port, hence this class cannot be used to communicate with this driver.

Any suggestions ?

I think I must have got the driver confused. that’s the exact issue why it does not working with mission planner.
I think the correct driver must be number 1 then.

As I wrote above none of the listed drivers works for me. The VisualGPSView works with the u-blox drivers and the W10 serial driver. MP 1.3.43 doesn’t work with my setup.
In Moving Base I can enter COM port, baud and refresh rate and click on Connect and the button changes to Stop (no errors) but the 0,0,0 display never changes and no icon appears on Flight Data screen.

please follow this guide

https://www.u-blox.com/sites/default/files/USBDriverWindowsSelectionGuide_(UBX-15022403).pdf

I have been following this guide and I tried all drivers several times on Windows 7 and 10. While VisualGPSView works fine, MP 1.3.48 shows no change in Flight Data screen to tell the position of the moving base and displays 0,0,0 instead of coordinates. Setting a Rally Point and checking the box doesn’t update the Rally Point.
Can you confirm there should be coordinates instead of 0,0,0 when it is working ?
How would the Flight Data screen look like - should it show a base icon ?

ok so it appears ublox gps’s now output gngga vs the old gpgga

please try the latest beta MP

THANK YOU ! (= now it works)