Problem with Mateksys ASPD-DLVR and CUAV PMU


i am pretty new to the UAVCAN hardware. (And Ardupilot as well)
My research group and me changed some i2c devices to UAVCAN for more fault tolenrance and more reliable data aquisition with long cables.

New setup:
Pixhawk 1 large memory ( i know, not the newest…) with newest Ardupilot firmware

Serial & i2c:

  • mRo GPS u-Blox Neo-M8N IST8308


  • Mateksys ASPD-DLVR airspeed sensor
  • Mateksys M9N F4 3100 GPS, Baro, Compass module

The airspeed sensor (changed the ID due to collision with GPS), GPS and PMU send their packets over UAVCAN as expected.
This is observed via the SLCAN inspector. (screenshot in attachements)

Unfortunately i only get airspeed data shown by mission planner if i power in a specific way:

  1. Power the Pixhawk over USB -> GPS and airspeed can-sensors are powered as well.
  2. Plug in main battery -> PMU is recognized. Everything seems to work. (We didn’t fly like this yet)

If i power first or only with the main battery at the PMU, the GPS and PMU is data is processed and showed (the SLCAN inspector looks identical!) but the airspeed stays at 0. No noise, no reaction to any wind inputs. (pressure difference in SLCAN is reported)

Neither the GPS nor the PMU sends any differential pressure data. (GPS sends ambient temperature)

I tried activating a second uavcan airspeed sensor and switching from primary to secondary sensor, but neither resulted in a working system.

It seems to me that Ardupilot somehow cant find the UAVCAN airspeed data in the UAVCAN stream when the PMU is attached during startup.


  1. Is the problem the changed ID? (i will try that in the next 2 days)
  2. Any ideas how to fix this?
  3. How is ardupilot initializing the airspeed sensor?
  4. Can i fix the UAVCAN-ID where the airspeed data is coming from?
  5. Can i provide any more logs/data/video that could help?

Thanks you a lot!

Christian Rieger

15tol_20210805_v007.param (18.7 KB)

Try BRD_BOOT_DELAY,1000 (up to 5000) and see if that helps

1 Like

seems like it worked. We will test it further in the next weeks. Thanks a lot!!!