Problem with Edit Waypoints window

I’ve never really used waypoints except a few times but since I started using APM Planner 2.0 on mac instead of 1.x version via Fusion, I’m getting a long list of waypoints like Nav Land, Nav Waypoint, etc. I can delete them one by one but sometime later I see more reappear. It’s not causing any problems but is this normal behavior? I don’t even have ADD WAYPOINT on a channel so I don’t know where the WPs are coming from.

Also when you press then X button at the bottom right, it just causes the never ending rainbow ball. Only way out is a force quit.

I’m using latest stable release or Planner and Copter.

I found out I was on rc3 so updated to rc4 and tried the x button to delete all waypoints and it didn’t hang. Still not sure why the waypoints are showing up since I’m not setting any but now I will write to clear them all and report back if they appear again.

I’m sure I’ve read a post on where somebody had the same issue and it was tracked down to to some incorrect setting. Can you post your param file so I can check if something is awry?

(Sorry couldn’t find the post when i searched :frowning: )