Servers by jDrones

Problem with DOWN facing rang finder when using Object Avoidance with Bendy Ruler

Hi, Good Evening to all,

I am making some mistakes in Object Avoidance with Bendy Ruler. Due to that mistakes, whenever I switched into an auto my HEXA copter is not take off. I am using 2 range finders (1. is DOWN facing(value 25) and 2.FORWARD facing range finder(Value is 0). Both belong to benewake. I am attaching a log file hear.

When I observing the log file it showing ERROR as “Err:Terrain-2”.
This error belongs to Terrain data. How can solve this total error, Please guide me.
I have done Different iterations :

  1. Take off directly in auto mode. (it did not lift off from the ground).
  2. Take off in Loiter mode and maintain some altitude, after I switch to auto. (Sudden falling in altitude).
  3. I did change in EK2_ALT_SOURCE=1. (there is no use).

Please find out my mistakes and guide me in the right direction.
Tomorrow(20-11-2020) Test flight wor flow is bellow:

  1. Enable MAVlink2 protocol in my ORANG CUBE.
  2. Enabling Terrain flowing.
  3. I need to test these changes tomorrow.

Please give me any suggestions for me to solve this problem.

Thanks and regards,
Mohan

Servers by jDrones