Servers by jDrones

Problem with avoiding

Hello, everybody.
These days I have finished installing the Lidar A2 and it works perfectly.
Now I’m configuring the obstacle avoiding but as you can see the rover that reaches the obstacle stops and makes some movement but without ever passing it. The configuration is in Benddy Rule.

Attached a video and the bin file in case you see the problem, I have changed parameters to find the problem but no luck
Thank you very much for your help
Bin:


Video:

@ecabanas,

Thanks for trying this out. I don’t see any BendyRuler messages in the log so it appears that BendyRuler isn’t running for some reason.

I was wondering if you could try this for me?

  • Load “latest” rover onto the autopilot. This can be done by pressing “Ctrl-Q” on MP’s Install Firmware screen. The version should become “Rover V4.0.1-dev”.
  • Ensuring Mission Planner is up-to-date. This can be done using MP’s Help screen. Push one of the Update buttons at the bottom.
  • Set ARMING_CHECK = 1 (we should resolve any issues with arming)
  • If the telemetry system has a lot of bandwidth, enable sending object location to the ground station by setting SRx_ADSB = 10 (where “x” is the serial port being used for the telemetry radio). After changing this you’ll need to reboot the autopilot

Thanks!

Hi

Thank’s for your help, but My Mission planner is up to date and when I’m going to firmware page, the MP offers me only the Rover 4.0, not dev…and obviously if I try to update the cube, the cube returns me that the unit has the same release

If I select beta firmware the result is the same.

Eduard

From the Install Firmware Screen Press Ctrl-Q. You will see this dialog box, press OK and load Rover 4.0.1 DEV.


Hi @dkemxr Thank’s for your help, I did and I upload the dev firm.
Hi @rmackay9 I uploaded the firm but with the same result, I attached the link to the log file if you can see something wrong…I’m lost

Thank’s all

@ecabanas,

OK, it looks like the vehicle is in Hold, Loiter, Manual and Steering mode in the logs but BendyRuler only does path planning when the vehicle is in Auto, Guided, RTL modes.

We will add some notes to the wiki page to make this more clear.

By the way, I think it would be good to set the OA_LOOKAHEAD to a larger value. 2m is very short. at least 5m would be a good value.

Setting OA_MARGIN_MAX to 25 is probably also too large. I’d reduce this to something small like 2m

Hi,

Thank’s for your help, now the lidar is connected to an external sbec and now the rover is going ok.
A simple mission has done but when I conected the “avoidance” the rover did not start correctly the mission.

It sims like crazy robot (see the video attached). Previously the mission was done perfectly and when avoidance is runing (with lidar) the robot did not start correctly.

I attached also the logs if can help to find what’s going wrong

Thank’s

log: https://www.dropbox.com/s/w45cykk8hk357e0/00000052.BIN?dl=0
video: https://www.dropbox.com/s/du8ipbtx1cwv4zu/IMG_0092.MOV?dl=0

Eduard

Servers by jDrones