Problem with APM Planer after the instillation on Macbook

Hello everyday,

I need some help from you gays.
I download the file of the installation from the web here (
After the driver installation I copy the App Apm Planer to application folder.
the problem start here after that I open the Apm planer!
in the right side on the top there are two small windows where I’m supposed to set the port speed and port type-COM.
But unfortunately the software shows me only two options:

  1. bluetooth-incoming-port
  2. bluetooth-modem
    !!! I attached photo !!!
    I know that I need to see some more options like COM or USB
    thanks to all helpful :slight_smile:


when plugged in you should see a device name usbmodemXXXXX

if not it means that you device is not working. see attached file.

Yes I know that I need to see this but in my Mac its not show!
In my pc(windows) its work good without any problem.
The driver is instal good I test it again.
Can you have please other Solution?

What version of OSX are you running?

OS X Mavericks 10.9.3

Accidentally posted this originally on the wrong thread :neutral_face: but I also have the same issue with my Macbook Pro I5 running Mavericks and APM 2.0

I use to run MP on a PC laptop but got very excited the other day when I discovered I could use APM Planner on my Mac!

Problem is trying to get it to recognise the USB port with the telemetry module plugged in. I also just get the Bluetooth and iPhone options.

I’ve installed the FTDI driver but get a little lost with all the ‘terminal’ instructions after the basic install.

Any assistance on how to get this working in everyday language would be much appreciated.

The problem is that I don’t know why it’s not working for you guys. If you have installed the the FTDI drivers, you should be able to see the Telemetry Radios.

Without installing any drivers you should be able to connect to PX4 and as it’s supported built in.

The APM2.5 looks like an Arduino Mega 2560, so works out of the box with OSX (see )

Which version of APM Planner 2.0 are you using? the latest in 2.0.10

Yes I running the last ver of APM 2.0.10
and I also instal the driver FTDI but its dont working at all!
I know some people that have the same problem on Mac with osx 10.9.3
I think its something in Mac preference but I dont know what…

Blue tooth modem is my only option… anyone find a fix?

I am running Mavericks on both an older iMac and a Macbook air. I can have that problem if I plug in the module AFTER I start up APM P. Perhaps your issue is more involved than that but might want to try and shut down APM P… remove and then plug in again the module… relaunch APM P and see if it’s in the list.

same problem here. I run APM Planner on a MBP with the latest OS X 10.9.3 and the latest APM Planner v2.0.10. I have the same issue like some writers above. I Only see the bluetooth connections.
I tryed to connect to my pixhawk from an old and a new MacBook pro.


Try turning your Bluetooth off and see if you can connect then.

Thanks for the hint, but I head tried this before with no success.
Any other Ideas?

I try everything that all of you write here and I still have this problem!
I rely don’t know what to do…
:cry: :cry: :cry:

please try the latest daily here

We did some major rework on the serial port handling to improve the stability. This new daily release fixes that. And it will be in the next 2.0.11 release.

thank you for the fast answer :slight_smile:
maybe you have a date for the release?
thank you. :slight_smile:

The target is this week for the release. We just have a feature to complete and to do some more testing of the serial port changes.

:stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue:
Excellent good to hear can’t wait…
thank to you and to all the people that do a Excellent work in this forum!!!
:stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue: :stuck_out_tongue:

I still dont success to connect with my MacBook!
please help me, what I need to do?