Problem setting up Batt Monitor

initial setup-Batt Monitor-Advanced-Calibration
The Measured Battery Voltage field is grayed out. There is no way to enter Measured Voltage.

On the setup page if I click on APM 2.6 power module I get a VOLTAGE 3.89 . I am using a 3S batt.

Something is not right.
If I go to the FULL PARAMETER LIST and set BATT-VOLT-MULT to 28 I get the right results.

Am I doing something wrong?

can you check what the PIN assignments are for BATT_VOLT_PIN and BATT_CURR_PIN?

This is what is shown in the debug console when I set it.

[quote]DEBUG 2014-04-23T16:25:54.974 "Set battMon:4 voltPin:13 voltDiv:10.010 currPin:12 aPerV:18.00"
DEBUG 2014-04-23T16:25:55.021 Received BATT_VOLT_PIN combo index to: 13
DEBUG 2014-04-23T16:25:55.021 APL::parameterChanged “BATT_VOLT_PIN” : 13
DEBUG 2014-04-23T16:25:55.022 Received paramter BATT_CURR_PIN
DEBUG 2014-04-23T16:25:55.022 APL::parameterChanged “BATT_CURR_PIN” : 12
DEBUG 2014-04-23T16:25:55.139 Received BATT_VOLT_MULT parameter
DEBUG 2014-04-23T16:25:55.140 APL::parameterChanged “BATT_VOLT_MULT” : 10.01
DEBUG 2014-04-23T16:25:55.140 Received BATT_AMP_PERVOLT parameter
DEBUG 2014-04-23T16:25:55.141 APL::parameterChanged “BATT_AMP_PERVOLT” : 18 [/quote]


Could there be something wrong with the VOLTAGE CURRENT SENSOR?

Tried again today. Went to the initial setup-Batt Monitor page . Clicked on APM 2.6 power module and everything worked. Huuum