Problem launching sim in SITL

I’m having some issues trying to get a SITL environment. The simulation doesn’t seem to do anything.

I’m running the simulation on OSX in a Vagrant container. Everything seems to have installed correctly and the sim appears to start up, but once I hit the mav prompt, it doesn’t seem like anything is happening. Also, it seems like qcontrol can connect to the instance via the UDP interface, but like the mav prompt, it doesn’t appear like the simulation is doing anything. It seems like qcontrol is connecting, but I get an error that qcontrol can’t download params. I’ve also tried to start the sim with the -w option. It looks like all the params get loaded, but no banana getting the sim to do anything.

I’ve attached a file that shows what I’m seeing. I’m hoping somebody can point out what I may be doing wrong.


Many thanks!,

Ok, a couple of dumb errors, but wasn’t really clear to me.

First, you MUST run as root! This solved the problem of the simulator not doing anything.

The problem that I solved after that involved not being able to get MavLink data out of the Vagrant/Ubuntu simulation. I solved that by determining my local IP address and appending --out:14550 to the shell command, thus it ended up looking like this:

vagrant ssh -c “sudo …/Tools/autotest/ -w -j 4 -v ArduPlane --out=”

This works like a champ!


You shouldn’t have to run as root. If this solved it it means you didn’t have permissions to access a resource that you needed.
But at least its working now.
Thanks, Grant.