Servers by jDrones

Problem Electronic Switch

Hi,
I bought the following product:

I have a pixhawk connected to the radio in PPM. Connected Electronic Switch to a pixhawk port it does not work.
If I connect the electronic switch to the receiver in PWM it works fine.
Can anyone help me?
Thanks.

Hi, I think you should use aux 5 or aux6 which are defined as relay switch.
Hope this help
Gal

What port are you connecting to? Make sure it’s enabled for PWM output with the BRD_PWM_COUNT parameter.

I tried to set up the relay switch but it still doesn’t work.

BRD_PWM_COUNT = 4

First I connected it to rc9 with option RCPassThru but it doesn’t work then to Aux5 (rc13) with the relay switch option but nothing.

Relay will output 3.3Vdc when activated, you have a PWM switch that needs >1500us to activate. BRD_PWM_COUNT=4 will give you PWM out on channels 9-12 (not 13). If you go back to Chan 9 (AUX1) and set SERVO9_FUNCTION to whatever RC Input channel you have configured a switch for it should work. Check the input level on Mission Planners’s Status screen to see of the RC In switch you configured is working and the Output channel is changing.

Do I put servo9_function to 1?
I seem to have done this as a first unsuccessful test.

Only if you are using RC input channel 9 as the switch.What channel did you configure on your transmitter for this function?

yes i am using RC input channel 9

OK, then assuming you don’t have anything else configured on RC9 (RC9_OPTION is 0) then do you see ch9 in and out change when you select the transmitter switch? Output needs to be >1500

Are you supplying power to the servo rail on the Pixhawk?

My rc9in and rc9out are at 2023. I have connected a servo to AUX1 and it works correctly.

Servers by jDrones