Problem connect sitl to mission planner

What I want to accomplish:
One prompt on WSL Ubuntu 18.04 running arducopter sitl
Second prompt on WSL Ubuntu 18.04 running mavproxy

Mission planner on windows 10
One prompt on windows 10 sending scripts.

What are the mavproxy commands to make all of this connect, I tried reading the wiki but I am very new to this, I dont even know very well the difference between UDP and TCP,

mavproxy.py --master tcp:127.0.0.1:5760 --out udp:192.168.1.20:14550 where 192.168.1.20 is the IP address of the W10 computer and 14550 is the output port.
On the W10 computer, in the mission planner connection dropdown menu, select UDP and type 14550 at the port prompt.
W10 and U18.04 computers must be on the same local network (connected to the same router).
Changed the category because question related to MAVProxy rather than arducopter.

I tried with my ip, but the mavproxy prompt couldn’t connect. Should I add output to the simulator?
I used the output command on the simulator mavproxy prompt, and then returned :
0: 127.0.0.1:14550
1: 127.0.0.1:14551

@Mustafa_Gokce When I tried that command, it gave me this:
Connect tcp:127.0.0.1:5760 source_system=255
Log Directory:
Telemetry log: mav.tlog
Waiting for heartbeat from tcp:127.0.0.1:5760
MAV> link 1 down

I am assuming you are starting the sitl with sim_vehicle.py
Does the below work for you?
mavproxy.py --master udp:127.0.0.1:14550 --out udp:192.168.1.20:14550
Again change the 192.168.1.20 with W10 IP address.
Do this command in a new terminal.

thx for the help, I ended up installing ubuntu and now all works