Problem Compas calibration (do not calibrate the dron)

Hello friends.
Something inexplicable has happened, has updated the mission planner and now I can not calibrate the drones (2 different APM arduoptero, ardupailot)
General data
ApM 2.8, without compass
Compass external M8N in GPS
Firmware installed in the APM 2.47.AP.3.1.1 AC 3.2.1

When arriving at a calibration compass I do not manage to make the graph move, to make the movements of the way of the circular way and nothing does not mark anything.

Friends has not made changes to the hardware of the computer so I do not understand what has happened

Please let the parents who help me identify them that have already passed the APM fail to be able to calibrate them

Tests performed
I already tried the following

  1. Uninstall the mission planner and install again
  2. Change the firmware of both drones
  3. Connect the compas to i2C as both are connected to the connector under the GPS and worked
  4. The APM of the F450 maintains internal companion, so it disables the external compass (disconnected the guitar cable and the bridge for the internal compass)
  5. Change 3 micro usb cables, thinking that it could be the cable that does not send the communication.

Pending your appreciation.

helppp. problem compas calibration