Prob controlling connection options

Installed 2.0.15.
upper right hand display = mav ID bluetooth -incoming port 115200
How do I change it to com 57600 or usb 115200 . Pull down list under COMMUNICATION does not offer links I am familiar with. I do not have BLUETOOTH equipment installed. Trying to use the 3DR telemetry link.

Click on the port name and a selection dialog will appear.

When I click on BLUETOOTH-INCOMING PORT a dialog box appears called serial link
there is a pull down list to the right of SERIAL PORT when I click on it there is only one choice BLUETOOTH-INCOMING PORT.

I assume you are running OS X. Which version? What hardware are you connecting to?

OSX 10.10 3DR radio set#2 with an APM2.6 controller

Try installing the FTDI drivers. They are included in the .dmg

I tried parallels MISSION PLANNER and it works as expected.

Running Windows in a VM uses a different device driver than the one installed in OSX.

I installed the driver. restarted everything. still the same. nogo

Then my other guess would be that when you plug your radio in the VM is grabbing the device and OSX cannot see it.

You could post a the APMPlanner 2.0 log.txt from apmplanner2 folder in your home folder

I looked in my applications folder and found the driver. the kind is a disk image. Is that correct?

I will have to figure what that means after I get a nights sleep. Thanks.

Yes, When you download the apm_planner2_latest_osx.dmg from and open it, you will see a FTDIUSBSerialDriver_v2_2_18.dmg. Open that and install the FTDIUSBSerialDriver_10_4_10_5_10_6_10_7.pkg installer.

Let me know if that works? (after some sleep :wink: )