Preventing the download of parameters when first connecting with Mission Planner

Is there some way to prevent the download of all the parameters from an APM controller to Mission Planner when Mission Planner first connects? I would prefer that all parameters not be downloaded every time the connection is first made.

I would love to know also.

For telemetry, I’m using both a RFD900 radio and a home-built 4G data link over Verizon (using a Raspberry pi) for redundancy and range. When one link becomes inoperable, I have to disconnect it and re-connect with a different protocol (RS-232 vs. tcp). I want Mission Planner to not re-download all the settings when I reconnect to the same craft using a different protocol, I just want it to continue using the same data. If I’m within radio range, I prefer that method, since Verizon charges for data.

The Cancel button on the Parameter Load window works without Cancelling the connection.

Is this not enough?

I’ll try it. I always avoided the CANCEL button because I thought it would break the connection.


No there is not. You can connect using control-t.

But there is a reason params are downloaded on every connect, and that’s because there are screen elements that depend on some of those parameters.

So I advise against it.

But I’m connecting to the same craft. The re-connect is a result of a failover from one communication method to another. The correct information should already be on the screen. I want the failover time that the craft is out of my control to be as short as possible. Reloading the parameters not only takes time, I think it would keep the flight controller busy and interfere with its operation somewhat.

I was unaware of the CTRL-T command. Thanks for that.