Prevent Mission Planner stream rate override

I am having trouble setting up the stream rates on Mission planner while running Arduplane SITL. I have a companion script that sets SET_MESSAGE_INTERVAL to around 20 hz, but MP overrides this command after a short while.

set the MP rate to -1 in the settings menu


Or set bit 12 in serialx_options for the telemetry port to ignore stream rate setting on that serial port.

Thank you for the quick response. Setting the MP rate to -1 works well. However, I would like to keep the same update rate (20 Hz) on both MP and the pymavlink script (I am not limited by bandwidth limitations of the datalink since I am only experimenting with SITL). Is this possible?