PreArm: RC Pitch not configured 3.5

Upgraded my Hex today with 3.5 getting PreArm: "RC Pitch not configured "error message. I reinstalled firmware and frame type, calibrated Accls ,radio and GPS. disabled Pre arm radio check and it flys well.

Just upgraded one more quad with 3.5 with the same error. Could be a Spectrum Sat error as each quad is using the same receiver type. The fix was to turn off PreArm for the radio. However the false flag is a issue.

I had the same issue. recalibrating my rc inputs worked for me.

Hello Freezer, I tryed that but had the same error after but i can give it a try to see if it goes away. thank you.

Try Manually changing your rc min and max values to something else and then recalibrate your rc again. I found once that my radio values ended on the same values as default on the roll. so the software thought nothing changed on that channel after calibration.


I have same issue. I disabled RC checked

Arducopter V3.5.5

Prearm check if the RC channel values (Max and Min) are touched in the parameter store. If not then it fires a not configured error.
If your RC receiver gives the exact same max and min values that the defaults, the params will not be updated even after a calibration. (no change, no update)
To overcome this you have to manually “touch” min and max parameters for the first four channels.
The easiest way is to increase them by 1 in the full parameter list (Mission planner) and write params. After this you can change it back to the default values, it become configured…

1 Like