Prearm: Rangefinder1: no data

my screen said this error. my lidar is gramin lidarlite v3. my pixhawk is orange cube.
what do i need to do in order to fix this?

I assume your not getting any readings for the lidar under rangefinder1? under mission planner>status tab

1 Like

yeah. it says 0 on rangefinder1

how have you connected the lidar ?
https://ardupilot.org/copter/docs/common-rangefinder-lidarlite.html

yes i connected the lidar through pwm

did you follow

  • [RNGFND1_TYPE] = 5 “PWM”
  • [RNGFND1_PIN] = 54 “AUX5”
  • [RNGFND1_MAX_CM] = 3500 (the maximum range the lidar can accurately report in cm)
  • [RNGFND1_MIN_CM] = 20 (the mininum range the lidar can accurately report in cm)
  • [RNGFND1_SCALING] = 1 (“0.8” may produce more accurate readings for some units)
  • [RNGFND1_OFFSET] = 0

What AUX port is it connected to, you need to set it to GPIO, AUX pins are servo_9-14 so if your lidar is connected to AUX 5 set SERVO_13 function -1

did you mean SERVO13_FUNCTION parameter?

yes SERVO13_FUNCTION parameter set to -1 assuming your connected to aux 5.