PreArm: Internal errors 0x400 l:234 cnstring_nan


Got this message - PreArm: Internal errors 0x400 l:234 cnstring_nan - after doing the COMPASSMOT.

Restart it and it was all good during the flight.

Cube Black + HERE3 (CAN) - Mini Carrier - 4.1.0


Any ideas what could it be?

1 Like

It’s a bug - I have seen this several times

1 Like

I have seen this also.

so what basically does it mean

I have just seen this too. I want to check the compass interference when the motors are running.

I am using Arducopter 4.1.3 with an official Pixhawk 1.

I have had this working back in January 2021 with whatever the Arducopter version was then. Has anyone actually had the magnetic/motor calibration test working in “recent” times?

Even with the “bug” Compassmot is still successful. At least that’s what I found.

I did not see any magnetic field at all on the graph.

I can calibrate my compass fine though on its own doing the x-y-z axis rotation calibration.

Ah, that’s different. What I saw was the error after the procedure completed but it worked.

I am using a separate standalone compass that is not built-in to the GPS.

My GPS has a compass which I am not using at all. I am using the Pixhawk compass but it is obviously the second compass since it will experience lots of noise.

My feeling is that this issue is related to using a standalone compass because I have had this drone working in the past doing magnetic interference tests but only when I used the compass built-in to the GPS.

Just experienced this issue as well with 4.1.4 on cube orange + Here3

1 Like

We got this IE (PreArm: Internal errors 0x400 l:234 cnstring_nan) after CompassMot calibration and SdCard logs download too

I also just got this on 4.1.3 on Cube Blue following a compass motor calibration.

Right and it completed?. The issue remains, carry on.

I’m getting the same 0x400 after running compas motor calibration, also requiring a restart to fix.
Both in QGroundcontrol and Missionplanner.
I’m also seeing a “Initialising Ardupilot” repeatedly (every 3 or so seconds) in the log.

I also have seen the ‘initializing ardupilot’ message during this… @dkemxr how do I tell if it completed correctly? It did complete, I did reboot and it started up fine, however I am reticent to fly the sUAS. It’s an octocopter that has already has 2 crashes and is not trust worthy whatsoever (yet).

Hello everybody !
I am using Cube Orange + Here3 firmware 4.3.2

PreArm: Internal errors 0x400 l:234 cnstring_nan
after CompassMot calibration
has anyone solved this problem?

I also noticed how one of the motors stops rotating during PreArm
1-2 times out of 10-15 attempts
Has anyone had this?
This problem occurs out of the blue and it’s confusing to me

1 Like

I would update to 4.3.3 (or latest stable) - there are important fixes for Cube Orange, and more.
hopefully you can do a test where you get the prearm error and maybe the motor problem.
upload that log somewhere and provide the link to it.

1 Like

thanks Shawn
here is the log

I dont see that error.
Definitely update firmware to 4.3.3 , you are still using 4.3.1 and there is very important fixes for the Cube Orange.

If you are concerned about 1 motor not starting up the same as the rest, then test with MissionPlanner motor test - but the related parameters look fine to me.
You can also do the “Calibrate Level” after actually levelling the copter, to make sure it knows it’s true attitude when arming.
Probably also set BRD_SAFETYENABLE,0 to stop using the “safety” switch and keep clear of those props.

You need to change your 3 position flight mode switch to Stabilise, AltHold and Loiter
Try arming and launching with Stabilise. You will need to manipulate the throttle constantly to maintain hover, switch to AltHold and let it learn the hover thrust for a couple of minutes.
Put Land and RTL on another switch - they can even work together with another 3 position switch if you have one.

I would definitely set these too:
Using battery capacity is great, except when you need to disconnect/reconnect the battery without also fully charging it. Or if cells are going bad over time.

1 Like

I will use your advice and do a test tomorrow
thank you Shawn