PreArm: Internal errors 0x100000 l:921 flow_of_ctr


We did first flight on this hexacopter today.
Suddenly the started climbing in Alt-Hold Mode without any throttle input
This happened 2-3 times before I was able to land the copter safely. LOG FILE DOWNLOAD
This bug is repeatable. I tried power cycling and tried again, same results.
I uploaded v4.2.3 and this issue was resolved, SO it seems its only there in v4.3.1

Are my parameters wrong or there’s a bug ?


Let’s see the V4.3.2 log, curious about something.

But as V4.3.2 is the Stable version why worry about a problem that it fixed?

1 Like

I’m not sure that there’s any bug related to altitude and climbing in this situation.
There’s definitely a bug with control loops and load that was fixed by 4.3.2, and you can see the warnings you are getting, but I dont think that is affecting altitude.

It just looks like it had not learned hover throttle, the value didnt change during that flight. In fact you were using Stabilise mode which would have been good to stay in when the copter started climbing, but you switched into AltHold which might have confused the situation a little. I’m sure Stabilise mode would have easily brought down the copter.

I would say then after you upgraded to 4.3.2 the next flight allowed the hover throttle the learn and save, and then reactions were as you expect.

Check that your rangefinder is configured correctly, or disable it as a test.

1 Like