PreArm: INS not healthy

Hi, I’m new to APM so apologies if I’m being dense.

Can’t get past the pre-arm checking. I have a freshly flashed APM 2.5 with v3.1.1 on my X quad. I ran through all of the mandatory setup but getting a “PreArm: INS not healthy” message when trying to arm.

I suspect the problem to be the compass or calibration of the compass. I’ve selected “APM with onboard, compass” and I’ve re-calibrated several times. Each time I end up with about the same values each time of x: -228, y: -70, z: -111.

I’m using a 15m usb cable so I don’t think the proximity to my laptop is an issue, but the x value seems extreme compared to the wiki which says it should be within +/- 150. I watched the youtube video and I’m following it pretty closely.



I used to get this message too.

My solution was to calibrate the accelerometers with MissionPlanner, you put your copter on different positions against a wall (letf side, right side, etc…) until the calibration is done. … elerometer


I had done all the required calibrations multiple times. When I updated the APM Planner and then the latest firmware (3.1.2), everything worked so it must have been one of those two.

Thanks for the reply though!