Servers by jDrones

Prearm: gps speed error 1.0


(marcmerlin) #1

I have HDOP at 1.07
GPS FIX: 4.0
GPS sats: 9
Arming gives prearm: gps speed error 1.0

I had to wait a long time (minutes) before getting
HDOP 0.86
Fix: 4.0
Sats: 11
and finally I was able to arm

Strangely if I power cycle, the next time it just arms without problems with HDOP 1.32.

Is the pre-arm being a bit too sensitive here? If I get this too often, do I need to turn off GPS altogether from pre-arm checks, or is there a better way?

I’m using the 3DR GPS with a pixhawk on a plane where the GPS is nowhere close anything else except the 2 cables going to it.


(marcmerlin) #2

So I’ve fixed my problem by having ARMING_CHECK set to
2+4+8+64+128+256+512+1024 = 1998

Turns out removing the GPS check is not necessary, but removing one of
16 INS
32 Parameters

makes the problem go way. I’m assuming it’s probably INS.
Sadly
plane.ardupilot.com/wiki/ardupla … ming_check
does not explain what INS or Parameters are

I believe I had this problem before AP 3.4, it’s just that it reset arming checks to 1 and brought this problem back for me.


(gmorph) #3

INS stands for INertial Sensors - your accels and gyros. You may need to calibrate them again before your next flight.

Parameters isn’t used yet.

I have updated the documentation for both. Should be published soon.

Thanks, Grant.


(marcmerlin) #4

Thanks, I’ll try a recalibration.
Although if my accelerators/gyros are not calibrated right, why am I getting a GPS pre-arm error?


(gmorph) #5

If you post Dataflash logs when you have the problem we will have a look.
Thanks, Grant.


(marcmerlin) #6

Here is one with
DEBUG 2015-10-30T08:54:46.593 APM: Text Message rx’d “PreArm: GPS horiz error 5.4”

DEBUG 2015-10-30T08:58:00.927 APM: Text Message rx’d “PreArm: GPS speed error 1.5”

Sadly, this also crashes apmplanner 2.0.19-rc4. Is there a mailing list or proper location to report apmplanner crashes?

DEBUG 2015-10-30T08:54:46.593 APM: Text Message rx’d "PreArm: GPS horiz error 5.4"
INFO 2015-10-30T08:54:46.593 “/home/merlin/apmplanner2/tmp_audio/Pre-arm_check:_GPS_horiz_error_5.4.wav” file not exist, create a new one
VAL: tried to access cart in -1 type val
[1]+ Exit 255 apmplanner2

DEBUG 2015-10-30T08:58:00.927 APM: Text Message rx’d "PreArm: GPS speed error 1.5"
INFO 2015-10-30T08:58:00.928 “/home/merlin/apmplanner2/tmp_audio/Pre-arm_check:_GPS_speed_error_1.5.wav” file not exist, create a new one
VAL: tried to access cart in -1 type val
[1]+ Segmentation fault (core dumped) apmplanner2


(marcmerlin) #7

For now, I’m using ARM_CHECK 2030 to turn off this check that keeps failing without good reason I can find and things seem to be ok in flight.
I’d love to know more or help find why this isn’t working as it should.


(marcmerlin) #8

Filed a bug for now:
github.com/diydrones/ardupilot/issues/3291


(rmackay9) #9

Those messages are coming from the EKF when the GPS velocity, acceleration and not consistent with the IMU (gyros + accels). That could either be because the data from the GPS isn’t good at the time, or maybe because of a bad accel or gyro cal. I actually suspect it’s just the GPS. The reason that it was fine even when rebooted is because the GPS has a battery in it, so that even if it’s rebooted it doesn’t look all the information it’s gathered.


(marcmerlin) #10

Howdy. I just now had the time to do a full gyro/compass recal in mission planner.
Same exact thing:
PreArm: GPS horiz error 9.3
PreArm: GPS horiz error 11.9
PreArm: GPS horiz error 5.7
I’ve put pream checks back to 2030, and I can arm again.
GPS HDOP is 1.31

I have a genuine pixhawk and a genuine 3DR compass module.
If we’re pretty sure it’s not a firmware issue, what can be causing this?


(Nicolas Grunbaum) #11

i’ve been having the same issue. I found that unchecking the geofence give no error. Even using the arming_check at 1 (so all enable).