"Prearm: Fence requires position"

I’m getting a new prearm warning since upgrading to 4.3: “Prearm: Fence requires position.”

When I go to my geofence settings, there are no options for “type:”

2022-11-23 07_18_11-Mission Planner 1.3.77 build 1.3.8110.38294 ArduCopter V4.3.0 (93448b71)

I never had this problem before and I think thre were options for “type” before…

Use the “full parameter list” to set that parameter. But you need to enable it first, reboot, and reconnect

I already have the type set to “altitude” and “circle.” I disabled it because of it not working (to remove the prearm error temporarily).

That is the wrong approach.

You should fix the pre arm errors, not disable them!!!

1 Like

As posted earlier, I wasn’t doing it as a fix, only temporarily (so as to allow other prearm errors.)

I agree that I should fix the prearm errors. That is why I am asking about it.

Are you sure you have GPS Fix and your EKF initialized position?

I had been looking for instructions on how to troubleshoot all those checks before you can arm the copter. All of these questions was answered after I installed YAPPU. It annouces all the important events like Fence aquired, GPS 3D fix aqired, GPS Home aquired and so on and so forth. If your radio and receiver can support YAPPU, its worth installing it.

I have it installed and in use. Currently, Yaapu reports on my radio “Yaapu telemetry ready.”

It should be reporting more messages. Not only Yaapu telemetry ready. Make sure that you have configured it properly expecially the telemetry settings. And add page 2 so you will see a better screen of the messages. Not a very pretty screen but for me, this screen tells everything. Its a list of all events so you don’t have to hunt those events somewhere else.

1 Like

You might be on to something here. I just checked my Yaapu (page 2) page on my Taranis X9D+ and I see “no telemetry!” and all information is not being received. I don’t know what could have changed this, since it has always been working fine, but looks like I should reinstall the latest version of Yaapu (mine is 3 years installed) and see if that solves things. Strange it stopped working.

For some reason, my SERIAL2_PROTOCOL had gotten changed to “2.” I was not discovering any sensors other than FLVSS and RSSI. Changing SERIAL2_PROTOCOL to “10” fixed my Yaapu. Now I get my screen 2 and see the same prearm warnings I see in Mission Planner:

“Prearm: Mount not healthy”
“Prearm: Safety switch”
“Prearm: Fence requires position”
“Prearm Check FS_THR_VALUE”

Nice, now fix it one by one.
To fix the “Fence requires position” all you need to do is wait for GPS lock.

2 Likes

This was the solution. I had to recalibrate my copter, because I was not getting a gps lock. Thanks for pointing it out.

1 Like

And have you also fixed the other 3?

Yes.

-This was due to my earlier experimenting with trying to install a Gremsy gimbal and having set my
type in Gimbal Settings in a previous firmware. Changing the value to “0” as sfacta suggested solved it.

-For some reason, my Taranis X9D+ controller must bounce below 975. Lowering my FS_THR_VALUE to 910 works.

-This is normal and only because I did not depress the safety switch.

1 Like

Nice man! Great job! Keep pushing!

1 Like