Prearm Failure: Q_ASSIST_SPEED

Hi all,

Another question for you:

I’m having issues arming my QuadPlane. I consistently get a “Prearm: Q_ASSIST_SPEED not set” error. Running Plane 4.2.2 on a Pixhawk4 with The Cube. All other arming checks are OK; I’ve calibrated the radio and ESCs, GPS and Airspeed are good.

I do not want any quadrotor assist for initial flights, and have set relevant parameters to zero:
Q_ASSIST_DELAY = 0.5 (default, haven’t touched)
Q_OPTIONS = (no bits set)
RCx_OPTIONS = (none are set to = 82)

I’m stumped here - any thoughts?


Hey Powell,

I think this should help, you can find the relevant description on the documentation page for Q_ASSIST_SPEED:


Up until Plane-4.1.7 setting Q_ASSIST_SPEED to zero used to disable it.

From Plane-4.2.0 onwards, setting it to zero provides assistance only during transitions. To disable the pre-arm check you’ll have to set Q_ASSIST_SPEED = -1.

When you go to the parameter reference page over at Complete Parameter List — Plane documentation, you can select the version as well by clicking on the dropdown at the top of the page:

Hope this helps, cheers!

1 Like

This absolutely solved the problem! Many thanks!

I was indeed reading the incorrect wiki version for my autopilot - completely missed the drop down menu at the top!

1 Like

You’re welcome! Happy to help :smile:

I have the same problem, but when I set -1 the system reports that the value is out of range and then even if I write it, after a refresh it is again 0. How can i solve ? Thank you very much