PreArm: check steering and throttle config error

upon configuring a new Pixhawk using the latest ArduRover (boat) firmware, I strumbled upon the error
PreArm: check steering and throttle config without any additional message.
Arming from RC or GCS gives the same error message.
Mandatory and optional hardware configuration have been performed and the compass disabled due to persistent “inconsistency error” triggered.

Main Out mapping

1 - Rudder (RC yaw input)
2 - Winch (RC roll input)
3 - Throttle (RC throttle input)

I think you should use “GROUND_STEERING” instead of “RUDDER”. “RUDDER” is for airplane yaw control.

Still not working. The servo n.1, assigned GROUND_STEERING function now works but both throttle and winch are unresponsive to commands.

At the moment I am using RC direct (SERVOX_FUNCTION = 1) with discrete results, all other functions except Ground steering don’t produce any output, I checked with a LED and an oscilloscope.

Do you still get any prearm errors?

No, I don’t get any error.
Anyway even when I get prearm errors, simply using the arm button will enable all servos.
On the param list I have all prearm checks enabled and battery cut off voltage set.h

The best thing would be to upload a dataflash log, so someone more knowlegdeable than me can have a look.