Servers by jDrones

PreArm: check firmware or FRAME_CLASS

I cant arm my drone it says " PreArm: check firmware or FRAME_CLASS" I already calibrated all but this message appear and also NO GPS detected and I’m using

pixhawk 2.4.8

Correct the value of the FRAME_CLASS parameter.

i obey what you’ve said now my drone is beeping

beeping is normal until you arm.

wait ill show you some clip what happened even tho i cant arm it it so crazy im also using a fs-i6x controller video : https://youtu.be/BvObGbdTxt4

whenever i switch it on my safety switch it goes beeping like you said its normal but only 1 esc is beeping is that normal i tho it should be 4 of them right?

Attached the parameter file here.

here are my parameter file I hope it helps I have this problem for a week right now

4.0.5version.param (18.0 KB)

It doesn’t look like you have done a radio calibration. One example of what won’t work. These should be around 1000 and 2000.
RC1_MAX,1573
RC1_MIN,1293

Make sure all trims are centered (and never move them) before running the Cal.

I suppose you mean the Radio. I’m not familiar with anything Flysky.

yes the radio aswell but im also having a problem setting up my Flysky controller

i finished my calibrating my radio ill try it again. ill update you on that but I set my aux switches to 8ch right but whenever I Radio calibration it only read 6ch it should be 8ch. my Flight controller is the FS-i6x sorry for my bad English I’m trying i hope it helps you understand my problem, sir.

I don’t know what you mean. There is a Transmitter, a Receiver and a Flight Controller. Perhaps it’s only a 6chan Transmitter?

so do you mean, I would need an 8 channel transmitter to work?

No, I mean you you can’t see 8 channels because you have a 6 chan radio… 6 Channels will work.

okay sir i will update you tomorrow with a video presentation. thank you for helping me

Hello sir, this is my video about my mission planner you should definitely check it for any cause of my problem is also not reading my GPS. the video: https://youtu.be/LJ-9uLm_1O8 4.0.5 updated.param (18.0 KB) thanks for helping me i hope it get things done :blush:

I think you have a 6 chan radio.
The radio is now calibrated.
You have the safety switch enabled. Is one connected and are you pressing it? If not set this parameter to 0. BRD_SAFETYENABLE

im pressing it whenever i turning on my drone but my main problem is now the GPS still not detecting from where im. i will send you a video update from my drone i hope it works now.

Servers by jDrones