PreArm:Battery one critical voltage failsafe

Flew my Quad today and keep getting either the “PreArm:Battery 1Low voltage failsafe”, “PreArm:Battery one below minimum arming voltage” or “PreArm:Battery one critical voltage failsafe” warning. Resetting my battery cell size from 4 cell to 3 cell allowed me to fly but it seemed like it reset the cell count back to 4 mid flight. After it did the the drone would go down and the propellers would still spin but now fast enough to get off the ground. After that if i tried arming again it would present of the the previously mention errors. I checked the voltage of my battery and its above the low voltage setting is also above the minimum arming voltage but it still refuses to arm. I tried playing around in the config settings with the minimum arming voltage, the crt volage failsafe, and the low voltage failsafe to see if it would work but now it just dose not arm at all even if i change the cell count to 3.

Hi Harry,
We will only know more from a .bin log.
Can you upload a log to a file sharing site and provide a link to it?

Likely causes are a battery that is in worse condition than you expected, or the voltage sensor has gone faulty (I’ve had that).
I’ve found that it’s best to set the voltage failsafe levels correctly for the battery being used then never change them. Then unexpected failsafes are a sure sign something needs fixing.


What @xfacta said, also: Did you check the voltage under idle or under load? There’s always a voltage drop under load, and with a failing battery it will get larger. I don’t recommend messing around with the settings (your battery has 4 cells, don’t tell Ardupilot that it has 3). 10 minutes flight time aren’t worth losing your drone over.