"PreArm: AHRS: EKF3 not started" won't go away

I’m almost ready to maiden a new plane, everything is set up. Yet while testing arming at home I get the above error, and nothing seems to make it go away. EK3_ENABLE,1. Should I try AHRS_EKF_TYPE = 2 as suggested in a older thread at Copter?


I’ve never had this before on any plane or copter. FC is F405-WSE with AP 4.3.0-dev (tried 2 different versions dating from a week apart, just in case).

Would be fantastic if this could be solved today as wind conditions look very good for tomorrow and not that good after that…

EDIT: Ok, I just found out switching to EKF2 isn’t even an option since it’s an 1MB board. So I’m not really sure what to try. I disabled compass, as there is none installed and on copter, it might be related to EKF not starting. No change.

EDIT 2: No change using stable either.

EDIT 3: “Solved” - I wasn’t aware that this is simply being caused by lack of GPS fix indoors, and I’m still wondering why I never saw this specific error before during my previous 5 or 6 AP/AC builds.

1 Like