Servers by jDrones

Pré arm - Gyros Inconsistent

Hello everyone

I have a problem that I can not solve. After all the initialization, if I delay to arm, the message “pre arm, gyros inconsistent” appears. I can only arm again if I restart the controller.

Any tips?

  • Pixhawk 1 3DR + MP 1.3.56 + AP 3.8.5

Thank you

recalibrate the copter, and this time make sure to follow all the suggestions while calibrating.

Recalibrate only the IMU? It’s an plane…

IMU and compass, yes …

re calibrating won’t help, unless you have turned off the automatic gyro cal on boot (the INS_GYR_CAL parameter)
There are three causes of gyro inconsistent errors:

  1. the aircraft was moving when it powered on (eg. wind on the wings). It needs to be held still while powering on, as it calibrates the gyro on boot. It doesn’t need to be level, but does need to be still
  2. if there was a significant temperature change since power on and the gyro is more sensitive than usual to temperature changes. If this is the issue a reboot will fix it
  3. the gyro is starting to fail. The IMUs do eventually age and start to get these types of problems. I’m afraid if this is the cause you need to replace the flight board

Good Morning!

Thank you for your help. Actually calibration did not solve the problem. @tridge Tridge, the second option seems to make more sense. I still have some questions:
1- The reading difference of the two gyros is normal (see image)?

2- Because of this reading difference, I did a test by turning INS_USE2 off. Immediately the problem disappears and I can arm. Is there any risk in flying with just one IMU?

3- What is the useful life of a controller?

Another question. I am using EK2_IMU_MASK = 3. Is this correct?

Good evening!

Today I made two flights and in the last one I had a problem, the message “altitude error” appeared a few times. The landing was bad. Is it related to the IMU problem mentioned above?

Thank you!

Flight 1 - Normal

Flight 2 - Problems

Is there a problem if I turn off IMU 2?

That uses IMU 1 and 2.

That will use the IMU 1 exclusively. the only issue is that you loose redundancy.

I did some testing recently with helicopters trying to solve loss of control issues with a EKF switch on these v3 controllers where IMU’s never seem to agree. I first did several days of simulated testing on the ground and figured out how to reliably produce a GPS glitch and subsequent rapid switching of the EKF processes. I thought I had it fixed by setting INS_USE2&3 to zero. So I tested in flight. I experienced total loss of control of the helicopter by initiating a GPS glitch on-purpose. The second attitude solution is totally different from the first, then it quickly switches again and another attitude solution that is different, it keeps playing musical chairs and the heli goes totally nuts. The only way to recover it (with helicopter) is to have flybar mode turned on and fly the aircraft no-gyro in Acro flight mode once the EKF goes bonkers.

The “fix” here was to set EK2_IMU_MASK to 1. It can then handle a GPS glitch and nothing bad happens. Or replace the controller with a decent one that has IMU’s that are consistent. The code allows up to 1 m/s/s difference on accelerometers before it will flag it on the pre-arm checks. But unless they are identical none of the supposed “redundancy” works when the EKF starts to rapidly switch “lanes”. You’re better off to just use one IMU, set up your system for pass-thru control that does not depend on any of this, and rely on your pilot skills for redundancy.

Thanks a lot for the help!!! I will do tests using only the IMU 1 !!!

I faced the same problem few weeks ago.
After connecting the power to the vehicle hold the vehicle stable don’t move it because after getting the power the vehicle runs the initialization of all the sensors. Continuously led blinks red-blue pattern during this initialization process.
By holding the vehicle stable during initialization I fixed the problem.
Try it.

Servers by jDrones