PPM + Spektrum receiver does not work


I want to use the PPM encoder v3 with my Spektrum AR6210 which has an additional satellite. RC: DX6i. However, if I connect the receiver (with satellite attached) to the PPM encoder and connect it to my pixhawk (2.4) and do a RC calibration (using MP) I get the following (strange) values:

Ch1: 1600-2007 (Roll)
Ch2: 1000-1403 (Pitch)
Ch3: 991-1412 (Throttle)
Ch4: 1600-2006 (Yaw)
Ch5: 991-1413 (Switch 1)
Ch6: 1592-2014 (Switch 2)

In consequence, I always get a “prearm: RC calibration” error and cannot arm the device. In addition (if I disable this check) the motors control does not work properly, i.e., only 2 motors are spinning, even at full throttle.

If I connect the satellite directly to the pixhawk, everything is fine (calibration as well as motors). However, I want to use the main receiver for increased range.

Here are the calibration values for satellite only:

Ch1: 1161-1945 (Roll)
Ch2: 1164-1937 (Pitch)
Ch3: 1061-1867 (Throttle)
Ch4: 1162-1944 (Yaw)
Ch5: 1061-1867 (Switch 1)
Ch6: 1151-1957 (Switch 2)

Any ideas what is wrong and how to fix this?
Thank you!

An update:

After connecting only the satellite to pixhawk (+do RC calibration) and changing to the main receiver, I do not have this strange behaviour any more. I even can use both the receiver and satellite together (as desired) connected to the PPM encoder. Now, RC calibration works as expected. Strange…

So, the workaround seems to be:

  • do RC calibration with satellite only (connected to pixhawk directly)
  • then switch to PPM encoder with the receiver + satellite
  • do RC calibration again.


Very strange, were you using only USB connection the first time you tried to configure? I’m thinking maybe could be not enough power going to the system.

Thank you for sharing the solution.

I also tried to configure it with the battery + USB connected, as I read about the power problem that could occur. However, I am not sure about the first trial - could be that the very first time I only used USB.